[GE users] qsh and OS X

Reuti reuti at staff.uni-marburg.de
Tue Jun 19 11:19:27 BST 2007


    [ The following text is in the "UTF-8" character set. ]
    [ Your display is set for the "ISO-8859-10" character set.  ]
    [ Some characters may be displayed incorrectly. ]

Am 19.06.2007 um 10:33 schrieb ?'??:

> If I use ssh -Y from the master or sub-nodes it works.

If you use "ssh -Y", the X11 will tunnel through ssh - only port 22  
is needed. This will work even with a firewall for other ports

Did you try to setup SGE to use ssh instead of rsh?

> I can run X applications on the MAC machine.

Yes, okay. But what if you "ssh" to a node (without using -X or -Y),  
and set then the display by hand as you would like to force SGE to  
do. Is it then also working?

-- Reuti


> If I try qrsh and then set the display it won't work.
> If I try qsh -display I don't get a xterm.
>
> So ...
>
> X is running on the MAC without a firewall
> The nodes are on a private network but I allow forwarding from the  
> master node,
> and set up a NAT table on the master node.
>
> All I get from qrsh is:
>
>
> Xlib: connection to "yam.weizmann.ac.il:0.0" refused by server
> Xlib: No protocol specified
>
> xterm Xt error: Can't open display: yam.weizmann.ac.il:0
>
>                          Regards,
>                            Jerry
>
>
>
> -----Original Message-----
>> From Reuti <reuti at staff.uni-marburg.de>
> Sent Mon 6/18/2007 6:02 PM
> To users at gridengine.sunsource.net
> Subject Re: [GE users] qsh and OS X
>
> Am 18.06.2007 um 16:15 schrieb Jerry Mersel:
>
>> I'm trying to run a interactive X job. The display is on a OS X
>> machine.
>>
>> I ran xhost + , and "qsh -display " but I can't seem to run X jobs
>> from
>> the nodes on OS X.
>>
>> Can someone please point me in the right direction.
>
> X11 is running on the Mac?
> The firewall on the Mac allows connections?
> There is a direct network connections between the Mac and the node,
> i.e. the nodes are not on a private (hidden) network?
>
> Another option might be to start just a qrsh session with a setup to
> use "ssh -Y" for the connection, and then start xterm there. Using
> "xhost +" is unsafe.
>
> -- Reuti
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
> For additional commands, e-mail: users-help at gridengine.sunsource.net
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
> For additional commands, e-mail: users-help at gridengine.sunsource.net

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net




More information about the gridengine-users mailing list