[GE users] SGE 5.3p6 broken since IP/subnet migration - need help!

Andy Schwierskott Andy.Schwierskott at Sun.COM
Mon Jun 25 21:06:58 BST 2007


    [ The following text is in the "ISO-8859-1" character set. ]
    [ Your display is set for the "ISO-8859-10" character set.  ]
    [ Some special characters may be displayed incorrectly. ]

Richard,

could there be an issue in the area of /etc/nsswitch.conf or ncsd 
configuration or just a plain routing issue to the ypserver/nameserver?

Has your /etc/hosts changed in the way how long and short names are listed?

How does the same user resolve the hostname? With "dig" or "nslookup" or 
with the gethostbyname utility in <sge_root>/utilbin/<arch>/?

Andy



Richard Hobbs schrieb:
> Hello,
> 
> We have recently migrated our network from a 192.168.3.0/255.255.255.0
> network to a 192.168.128.0/255.255.128.0 network, and since doing so, our
> qmaster will not start.
> 
> We keep getting the following:
> 
> ======================================================================
> [root at stg2 sge]# /etc/init.d/rcsge start
>    starting sge_qmaster
> critical error: can't check for running qmaster: can't resolve service
> "sge_commd/tcp"
>    starting sge_schedd
> error: can't resolve hostname "stg2.domain.co.uk"
> error: can't get configuration from qmaster -- backgrounding
>    starting sge_execd
> critical error: can't enroll to commd: CANT GET SERVICE
> [root at stg2 sge]#
> ======================================================================
> 
> Does anyone know what is causing this?
> 
> I have even tried a global find and replace of the old IP address range
> for the new IP address range, but it still doesn't startup.
> 
> I'm getting desperate now, and have no ideas left, so any suggestions are
> gratefully received! :-)
> 
> Just for the record, the same user on the same machine in the same
> terminal *can* resolve stg2.domain.co.uk, as below:
> 
> ======================================================================
> [root at stg2 sge]# host stg2.crl.toshiba.co.uk
> stg2.domain.co.uk has address 192.168.144.2
> [root at stg2 sge]#
> ======================================================================
> 
> And yes - i've also tried adding stg2.domain.co.uk to /etc/hosts, but the
> qmaster just will not start.
> 
> Please help! :-)
> 
> Thanks in advance,
> Richard.
> 

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net




More information about the gridengine-users mailing list