[GE users] qmake errors

Davide Cittaro davide.cittaro at ifom-ieo-campus.it
Thu Jun 28 13:38:36 BST 2007


Hi all, I have some problems in running qmake.
First of all it complains about a not set SGE_ARCH variable:
qmake: *** cannot determine architecture from environment variable  
SGE_ARCH
            no default architecture set
Your "qrsh" request could not be scheduled, try again later.

reading the docs I should export SGE_ARCH to avoid first error and  
ARCH to avoid the second one (I guess both variable should take the  
same value, lx26-amd64). It still doesn't work and I still get the

Your "qrsh" request could not be scheduled, try again later.

Error message.
qstat -j says that

Jobs can not run because the resource requirements can not be satified
         29773

Jobs can not run because queue instance is not in queue list of PE
         29773

Jobs can not run because available slots combined under PE are not in  
range of job
         29773

The first message doesn't mean anything to me.
The second message... well, in queue configuration, under pe_list, I  
have

pe_list               make,[@fast=lam_mpi pvm]

that means, to me, that make parallel environment is listed
The third message... I don't know how to interpret. It is also true  
that I'm pretty sure the followin pe configuration is somehow wrong:

$ qconf -sp make
pe_name           make
slots             60
user_lists        l-bioinf s-comp t-xtal
xuser_lists       NONE
start_proc_args   NONE
stop_proc_args    NONE
allocation_rule   $round_robin
control_slaves    TRUE
job_is_first_task FALSE
urgency_slots     min

You may help me in writing a decent make configuration, this has been  
messed up some time ago and never used after that :-(
Thanks

d

/*
Davide Cittaro
HPC and Bioinformatics Systems @ Informatics Core

IFOM - Istituto FIRC di Oncologia Molecolare
via adamello, 16
20139 Milano
Italy

tel.: +39(02)574303007
e-mail: davide.cittaro at ifom-ieo-campus.it
*/





More information about the gridengine-users mailing list