[GE users] Problem " your job is not allowed to run in any queue"

Jon Forrest jlforrest at berkeley.edu
Fri Mar 2 22:49:43 GMT 2007


    [ The following text is in the "ISO-8859-1" character set. ]
    [ Your display is set for the "ISO-8859-10" character set.  ]
    [ Some special characters may be displayed incorrectly. ]

I just inherited management of a Warewulf cluster.
The disk containing a working SGE configuration broke
just as I started managing this cluster so my first
task was to re-install SGE (Scientific Linux 4-3, x86_64,
Warewulf, 29 nodes). The broken disk had contained the SGE_ROOT
and was mounted on all the nodes in the cluster.

I replaced the broken disk, mounted it on all the nodes,
downloaded the 6.0u10 common and amd64 tar files,
and did what appeared to me to be a correct
installation of the head node. However, when
I ran the

./inst_sge -m -x -auto ./util/install_modules/my_configuration.conf

command (after editing the .conf file for my cluster) I got
the following error message (my cell name is allostery):

------------------------
Starting qmaster installation!

Installing Grid Engine as user >sge<

Your $SGE_ROOT directory: /opt/sge

Using SGE_QMASTER_PORT >2001<.

Using SGE_EXECD_PORT >2001<.

Using >allostery< as CELL_NAME.
The cell name you have used and the bootstrap already exists!
It seems that you have already a installed system.
A installation may cause, that data can be lost!
Please, check this directory and remove it, or use any other cell name
Exiting installation now!
------------------------------

This made me think that there was nothing that needed to be done on
the compute nodes. Indeed, after starting the execd daemon on all the
nodes, the qhost command shows them all. This was good, I thought.

So, I tried submitting the simple.sh test job. The result was

------------------------------
Unable to run job: warning: root your job is not allowed to run in any queue
Your job 14 ("simple.sh") has been submitted.
Exiting.
-------------------------------

(I'm doing this as root but somebody tried the same thing as a non-root 
user and has the same problem).

I searched far and wide for this error message and I found a thread on
this list from 12/2005 from somebody with the same problem but it
appeared that it went away when she moved to a later version.

Any help would be appreciated.

Cordially,
-- 
Jon Forrest
Unix Computing Support
College of Chemistry
173 Tan Hall
University of California Berkeley
Berkeley, CA
94720-1460
510-643-1032
jlforrest at berkeley.edu

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net




More information about the gridengine-users mailing list