[GE users] Bug in 6.1 installer when installing on FC6

Ian Levesque ian at crystal.harvard.edu
Fri May 11 04:28:39 BST 2007


Hi all,

I didn't see this mentioned on the mailing lists, so I figured I'd  
post my findings when trying to install GE 6.1 on a FC6 box (x86_64,  
but it would probably affect 32-bit installs, too).

The installer complains that the system is UNSUPPORTED:
Architecture UNSUPPORTED-lx24-GLIBC-2.5,-amd64 not supported by this  
procedure

It's a parsing bug in $SGE_ROOT/util/arch, line 243:
libc_version=`echo $libc_string | tr ' ' '\n' | grep "2\." | cut -f 2  
-d "."`

On the FC6 box, that translates to:
echo "GNU C Library stable release version 2.5, by Roland McGrath et  
al." | tr ' ' '\n' | grep "2\." | cut -f 2 -d "."

with the result of: "5,"

I fixed the issue by altering the case statement in util/arch to  
accept "3|4|5*)" on line 248

Best,
Ian


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net




More information about the gridengine-users mailing list