[GE users] consumables(licenses) and paralell environment not working...

Lönroth Erik erik.lonroth at scania.com
Wed May 16 08:05:07 BST 2007


    [ The following text is in the "iso-8859-1" character set. ]
    [ Your display is set for the "ISO-8859-10" character set.  ]
    [ Some special characters may be displayed incorrectly. ]

My pe looks like this:

# Version: 6.0u8
# 
# DO NOT MODIFY THIS FILE MANUALLY!
# 
pe_name           fluent_ts103_pe
slots             9999
user_lists        NONE
xuser_lists       NONE
start_proc_args   /opt/gridengine/mpi/myrinet/startmpi.sh -catch_rsh $pe_hostfile /opt/mpich/myrinet_mx2g/gnu/bin/mpirun.ch_mx
stop_proc_args    /opt/gridengine/mpi/myrinet/stopmpi.sh
allocation_rule   $fill_up
control_slaves    FALSE
job_is_first_task FALSE
urgency_slots     min

As you see I'm using myrinet_mx and apart from that I think this should work... My queues are setup with 4 slots and "UNDEFINED" processors.

/Erik


-----Original Message-----
From: Dan.Templeton at Sun.COM [mailto:Dan.Templeton at Sun.COM] 
Sent: den 15 maj 2007 16:51
To: users at gridengine.sunsource.net
Subject: Re: [GE users] consumables(licenses) and paralell environment not working...


Erik,

The naive assumption would be that your PE has the slots attribute set to 0.

Daniel

Lönroth Erik wrote:
>
> I have problems getting jobs through in my SGE 6u8 environment.
>
> I have setup a license load_sensor as decribed by
> http://bioteam.net/dag/sge-flexlm-integration/
> but when I submitt jobs and specify:
>
> #$ -l fluent_all=1
> #$ -l fluent_par=8
>
> I get from the scheduler:
>
> qstat -j 113
> ...
> ...
> ...
> script_file:                fluent.job
> parallel environment:  fluent_*_pe range: 8
> scheduling info:            cannot run in PE "fluent_ts102_pe" because 
> it only offers 0 slots
>                             cannot run in PE "fluent_ts103_pe" because
> it only offers 0 slots
>
> If I dont include the "-l fluent_xxx" resources, it works as normal.
>
> What am I doing wrong? I recall this has worked before, but now it
> seems not to.
>
> /Erik
>

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net




More information about the gridengine-users mailing list