[GE users] starting qlicserver from an init script

Glenn Johnson gjohnson at srrc.ars.usda.gov
Tue May 22 16:26:10 BST 2007


On Tue, 2007-05-22 at 09:35 -0400, Chris Dagdigian wrote:
> Do you source the gridengine setup script in your init script?

No, but I do have SGE_ROOT and friends defined. I am attaching the init
script to this email. This is on a Gentoo system. The script is run
with /sbin/runscript so I suspect that may be the problem.

Thanks.

> Regards,
> Chris
> 
> 
> 
> 
> On May 22, 2007, at 12:55 AM, Glenn Johnson wrote:
> 
> > I have my qlicserver set up as per the URL:
> >
> > http://wiki.gridengine.info/wiki/index.php/Olesen-FLEXlm-Integration
> >
> > Everything is working as it should (after some editing) except for  
> > one thing. I would like to start the qlicserver from an init script  
> > rather than a loadsensor. However, when I start it from an init  
> > script with the '-d' flag, the process will not daemonize. If I  
> > start it from the command line it goes into deamon mode and updates  
> > at the designated interval. But from an init script, it just runs  
> > once (with the correct output) and then exits, as if the '-d' flag  
> > is not recognized. Any ideas?
> >
> > Thanks.
> >
> > --
> > Glenn Johnson
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
> > For additional commands, e-mail: users-help at gridengine.sunsource.net
> >
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
> For additional commands, e-mail: users-help at gridengine.sunsource.net
> 
-- 
Glenn Johnson <gjohnson at srrc.ars.usda.gov>


    [ Part 2: "Attached Text" ]

    [ The following text is in the "utf-8" character set. ]
    [ Your display is set for the "ISO-8859-10" character set.  ]
    [ Some characters may be displayed incorrectly. ]

#!/sbin/runscript
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $

SGE_ROOT=/usr/local/sge
SGE_CELL=default
SGE_ARCH=`$SGE_ROOT/util/arch`
LM_LICENSE_FILE=@node1
PATH=$PATH:$SGE_ROOT/bin/$SGE_ARCH

export SGE_ROOT SGE_CELL SGE_ARCH LM_LICENSE_FILE PATH

depend() {
	need sgemaster
}

start() {
	$SGE_ROOT/flex-grid/site/qlicserver -dq
}

stop() {
        $SGE_ROOT/flex-grid/site/qlicserver -k
}



    [ Part 3: "Attached Text" ]

    [ The following text is in the "iso-8859-1" character set. ]
    [ Your display is set for the "ISO-8859-10" character set.  ]
    [ Some special characters may be displayed incorrectly. ]

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net



More information about the gridengine-users mailing list