[GE users] Job priority

Rayson Ho rayrayson at gmail.com
Wed May 23 19:19:02 BST 2007


    [ The following text is in the "WINDOWS-1252" character set. ]
    [ Your display is set for the "ISO-8859-10" character set.  ]
    [ Some special characters may be displayed incorrectly. ]

Unless you are the admin user, you can lower the priority but no upper it:

qsub(1) manpage:
          Users may only decrease the  priority  of  their  jobs.
          Grid   Engine  managers  and  administrators  may  also
          increase the priority associated with jobs. If a  pend-
          ing job has higher priority, it is earlier eligible for
          being dispatched by the Grid Engine scheduler.

And, "Job Sorting":
http://docs.sun.com/app/docs/doc/817-5677/6ml49n2bs?q=seq_no&a=view

* POSIX priority.
You can use the ?p option to the qsub command to implement
site-specific priority policies. The ?p option specifies a range of
priorities from ?1023 to 1024. The higher the number, the higher the
priority. The default priority for jobs is zero.

Rayson



On 5/23/07, Brian Pontz <bpontz at ll.mit.edu> wrote:
> Same way. Basically as a test I ran a loop and it would submit about 500
> jobs with random priorities from 0 to 1024.
>
> Brian
>
>
> On Wed, 2007-05-23 at 14:03 -0400, Rayson Ho wrote:
> > And how were other jobs with different priorities submitted??
> >
> > Rayson
> >
> >
> >
> > On 5/23/07, Brian Pontz <bpontz at ll.mit.edu> wrote:
> > > SGE version is 6.0u8
> > >
> > > Jobs are submitted via
> > >
> > > qsub -p 20 -cwd  -o /dev/null -e /dev/null /home/user/test.sh
> > >
> > >
> > > Brian
> > >
> > >
> > > On Wed, 2007-05-23 at 12:48 -0400, Rayson Ho wrote:
> > > > What SGE version?? And, how did you submit the jobs and specify the priority??
> > > >
> > > > Rayson
> > > >
> > > >
> > > >
> > > > On 5/23/07, Brian Pontz <bpontz at ll.mit.edu> wrote:
> > > > > Hi,
> > > > >
> > > > > I'm wondering if there is any known issues/bugs with setting job
> > > > > priorities? I've been testing it out and no matter what priority I set
> > > > > when submitting a job using qsub, they all end up getting run in the
> > > > > order I submit them. This is in the all.q queue. Is there anything in
> > > > > particular I should be looking at to help debug this problem?
> > > > >
> > > > > Thanks,
> > > > > Brian
> > > > >
> > > > >
> > > > > ---------------------------------------------------------------------
> > > > > To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
> > > > > For additional commands, e-mail: users-help at gridengine.sunsource.net
> > > > >
> > > > >
> > > >
> > > > ---------------------------------------------------------------------
> > > > To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
> > > > For additional commands, e-mail: users-help at gridengine.sunsource.net
> > > >
> > >
> > > ---------------------------------------------------------------------
> > > To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
> > > For additional commands, e-mail: users-help at gridengine.sunsource.net
> > >
> > >
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
> > For additional commands, e-mail: users-help at gridengine.sunsource.net
> >
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
> For additional commands, e-mail: users-help at gridengine.sunsource.net
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net




More information about the gridengine-users mailing list