[GE users] Whither libdb 4.4?

skip at pobox.com skip at pobox.com
Fri May 25 17:02:15 BST 2007


After the agony I experienced trying to install sge from source the past
couple of days, y'all convinced me to do a binary install.  That I did this
morning.  While sanity checking the installation I ran:

    for f in `find .  -type f | xargs file | egrep ELF | awk -F: '{print $1}'`
    do
        echo $f
        ldd $f | egrep 'not found'
    done

This turned up these problems:

    ./utilbin/sol-x86/berkeley_db_svc
            libdb-4.4.so =>  (file not found)
    ./utilbin/sol-x86/db_archive
            libdb-4.4.so =>  (file not found)
    ./utilbin/sol-x86/db_checkpoint
            libdb-4.4.so =>  (file not found)
    ./utilbin/sol-x86/db_deadlock
            libdb-4.4.so =>  (file not found)
    ./utilbin/sol-x86/db_dump
            libdb-4.4.so =>  (file not found)
    ./utilbin/sol-x86/db_load
            libdb-4.4.so =>  (file not found)
    ./utilbin/sol-x86/db_printlog
            libdb-4.4.so =>  (file not found)
    ./utilbin/sol-x86/db_recover
            libdb-4.4.so =>  (file not found)
    ./utilbin/sol-x86/db_stat
            libdb-4.4.so =>  (file not found)
    ./utilbin/sol-x86/db_upgrade
            libdb-4.4.so =>  (file not found)
    ./utilbin/sol-x86/db_verify
            libdb-4.4.so =>  (file not found)

I see there is a libdb-4.4.so in lib/sol-x86.  Do I need to explicitly set
LD_LIBRARY_PATH for any commands I run or will these various utilities all
be front-ended by some shell script which will set LD_LIBRARY_PATH
correctly?  I didn't see anything obvious with a quick grep of the installed
shell scripts.

Thx,

-- 
Skip Montanaro - skip at pobox.com - http://www.webfast.com/~skip/

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net




More information about the gridengine-users mailing list