[GE users] Permission problems in install_qmaster

skip at pobox.com skip at pobox.com
Sat May 26 18:50:49 BST 2007


    Rayson> On ther other hand, if you set up with spool classic (there is
    Rayson> an option for you to pick during install), then you should be
    Rayson> able to skip this problem.

Eh...  Not so much.  Starting with a new SGE_ROOT on the local disk owned by
skipm:develop I ran install_sqmaster as root and selected classic spool.
That croaked with

    error: common directory "/var/opt/sge/default/common" does not exist
    critical error: can't create directory "/var/opt/sge/default/common": No such file or directory

    Command failed: ./utilbin/sol-x86/spoolinit classic libspoolc /var/opt/sge/default/common;/var/opt/sge/default/spool/qmaster init

    Probably a permission problem. Please check file access permissions.
    Check read/write permission. Check if SGE daemons are running.

Looking at what it had created up to that point I see this:

    % pwd
    /var/opt
    % ls -lR sge
    sge:
    total 2
    drwxr-xr-x   3 root     root         512 May 26 12:33 default

    sge/default:
    total 2
    drwxr-xr-x   3 root     root         512 May 26 12:33 spool

    sge/default/spool:
    total 2
    drwxr-xr-x  19 skipm    root         512 May 26 12:33 qmaster

    sge/default/spool/qmaster:
    total 34
    drwxr-xr-x   2 skipm    develop      512 May 26 12:33 admin_hosts
    drwxr-xr-x   2 skipm    develop      512 May 26 12:33 calendars
    drwxr-xr-x   2 skipm    develop      512 May 26 12:33 centry
    drwxr-xr-x   2 skipm    develop      512 May 26 12:33 ckpt
    drwxr-xr-x   2 skipm    develop      512 May 26 12:33 cqueues
    drwxr-xr-x   2 skipm    develop      512 May 26 12:33 exec_hosts
    drwxr-xr-x   2 skipm    develop      512 May 26 12:33 hostgroups
    drwxr-xr-x   2 skipm    develop      512 May 26 12:33 job_scripts
    drwxr-xr-x   2 skipm    develop      512 May 26 12:33 jobs
    drwxr-xr-x   2 skipm    develop      512 May 26 12:33 pe
    drwxr-xr-x   2 skipm    develop      512 May 26 12:33 projects
    drwxr-xr-x   2 skipm    develop      512 May 26 12:33 qinstances
    drwxr-xr-x   2 skipm    develop      512 May 26 12:33 resource_quotas
    drwxr-xr-x   2 skipm    develop      512 May 26 12:33 submit_hosts
    drwxr-xr-x   2 skipm    develop      512 May 26 12:33 users
    drwxr-xr-x   2 skipm    develop      512 May 26 12:33 usersets
    drwxr-xr-x   2 skipm    develop      512 May 26 12:33 zombies

I'm a little suspicious about the ownership of sge/default,
sge/default/spool and sge/default/spool/qmaster.  I changed them to
skipm:develop and reran without deleting anything.  Again I selected classic
spooling.  I got an error about /var/opt/sge/default/common being missing,
but it plowed ahead.  Then I got to the same place and it croaked with the
same error message:

    Command failed: ./utilbin/sol-x86/spooldefaults configuration /tmp/configuration

    Probably a permission problem. Please check file access permissions.
    Check read/write permission. Check if SGE daemons are running.

Skip

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net




More information about the gridengine-users mailing list