[GE users] debugging daemons with SGE_DEBUG_LEVEL

Kirk Patton kpatton at montalvosystems.com
Wed May 30 23:00:26 BST 2007


    [ The following text is in the "utf-8" character set. ]
    [ Your display is set for the "ISO-8859-10" character set.  ]
    [ Some characters may be displayed incorrectly. ]

Hello Daniel,

I de-hacked the dl.sh script to remove the redundent 'dl $1', I had added, but 
I still get nothing from the daemon when I enable debug.

It works fine with sge commands, but I cannot get any output from sge_execd.  Are you able to get sge_execd to send debug info to STDOUT with 'dl 5'?

Kirk

----- "Daniel Templeton" <Dan.Templeton at Sun.COM> wrote:
> Kirk,
> 
> You should be using:
> 
> #Set debug level
> . ${SGE_ROOT}/util/dl.sh
> dl 5
> echo $SGE_DEBUG_LEVEL
> 
> 
> For more debugging info, see:
> 
> http://blogs.sun.com/templedf/entry/using_debugging_output
> 
> Daniel
> 
> 
> Kirk Patton wrote:
> > Hello,
> >
> > I would like to get the daemons to output debug information so that
> I can glean some additional information reguarding a problem we have
> been having.  
> >
> > I have tried modifying the startup script for sge_execd as a test
> before I try it for sge_schedd.
> >
> > Although I have set the debug level using dl.sh, I get no debug
> output reguarless of the debug level I try.
> >
> > Here is the snipped I am using in the startup script
> /etc/init.d/sge_execd.
> >
> > ...
> > SGE_ROOT=/import/tools/sge/6.0; export SGE_ROOT
> > SGE_CELL=default; export SGE_CELL
> >  
> > #Set debug level
> > . ${SGE_ROOT}/util/dl.sh 5
> > echo $SGE_DEBUG_LEVEL
> > ...
> >
> >
> > After I restart the script, I get a message at the terminal that
> sge_execd is starting and the daemon is in the forground, but I never
> have seen any debug output.
> >
> > Am I doing something wrong?
> >
> > Thanks,
> > Kirk
> >
> > Here is the script I am calling.
> > ...
> > dl() {
> >    case "$1" in
> >       0) unset SGE_DEBUG_LEVEL; unset SGE_ND ;;
> >       1) SGE_DEBUG_LEVEL="2 0 0 0 0 0 0 0"; export SGE_DEBUG_LEVEL;
> SGE_ND="true"; export SGE_ND ;;
> >       2) SGE_DEBUG_LEVEL="3 0 0 0 0 0 0 0"; export SGE_DEBUG_LEVEL;
> SGE_ND="true"; export SGE_ND ;;
> >       3) SGE_DEBUG_LEVEL="2 2 0 0 0 0 2 0"; export SGE_DEBUG_LEVEL;
> SGE_ND="true"; export SGE_ND ;;
> >       4) SGE_DEBUG_LEVEL="3 3 0 0 0 0 3 0"; export SGE_DEBUG_LEVEL;
> SGE_ND="true"; export SGE_ND ;;
> >       5) SGE_DEBUG_LEVEL="3 0 0 3 0 0 3 0"; export SGE_DEBUG_LEVEL;
> SGE_ND="true"; export SGE_ND ;;
> >       6) SGE_DEBUG_LEVEL="32 32 32 0 0 32 32 0"; export
> SGE_DEBUG_LEVEL; SGE_ND="true"; export SGE_ND ;;
> >       8|7) echo dl: $1 is a still unused debugging level ;;
> >       9) SGE_DEBUG_LEVEL="2 2 2 0 0 0 0 0"; export SGE_DEBUG_LEVEL;
> SGE_ND="true"; export SGE_ND ;;
> >       10) SGE_DEBUG_LEVEL="3 3 3 0 0 0 0 3"; export SGE_DEBUG_LEVEL;
> SGE_ND="true"; export SGE_ND ;;
> >       *) echo "usage: dl <debugging_level>"
> >          echo "       debugging_level 0 - 10"
> >    esac
> > }
> >  
> > dl $1
> >
> >
> >
> >
> >
> >
> ---------------------------------------------------------------------
> > To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
> > For additional commands, e-mail:
> users-help at gridengine.sunsource.net
> >
> >


-- 
Kirk Patton x5585
Sr. systems Administrator
Montalvo Systems

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net




More information about the gridengine-users mailing list