[GE users] Help with qrsh, SSH, and LDAP

Darin Perusich Darin.Perusich at cognigencorp.com
Tue Nov 6 22:36:01 GMT 2007


    [ The following text is in the "windows-1252" character set. ]
    [ Your display is set for the "ISO-8859-10" character set.  ]
    [ Some special characters may be displayed incorrectly. ]

While not using qrsh/ssh I am using LDAP for users and groups on my 
Linux/Debian exec-hosts, this is an OS issue not an SGE issue. Are you 
seeing the nss_ldap errors with any other services? Also you might want 
to try and disable nscd on the clients. While it's suppose to speed 
things up I've found that it does just the opposite and causes timeouts 
on Linux when used with LDAP.

Can you provide your nsswitch.conf, /etc/ldap.conf and 
/etc/openldap/ldap.conf files?

David Olbersen wrote:
> Nobody has any experience with qrsh, ssh, and LDAP?
> 
> Do I need to upgrade to 6.1?
> 
> Anybody?
> 

> And on the exechost (1 host in this queue) I see this in /var/log/messages
> 
>  
> 
> Nov  5 09:54:42 node-2 sge_shepherd-1019: nss_ldap: reconnecting to LDAP 
> server...
> 
> Nov  5 09:54:42 node-2 sge_shepherd-1019: nss_ldap: reconnected to LDAP 
> server after 1 attempt(s)
> 
>  
> 
> I can?t quite tell what?s going on here and could really use some help. 
> All machines run CentOS 4.4, if that?s of any use. This is a lab cluster 
> so I?m free to experiment. As I said above, SSH works outside.
> 

-- 
Darin Perusich
Unix Systems Administrator
Cognigen Corporation
395 Youngs Rd.
Williamsville, NY 14221
Phone: 716-633-3463
Email: darinper at cognigencorp.com

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net




More information about the gridengine-users mailing list