[GE users] problems with integrating execution node under aix 5.3 to existin g grid environment

Rayson Ho rayrayson at gmail.com
Thu Sep 6 17:01:17 BST 2007


    [ The following text is in the "ISO-8859-1" character set. ]
    [ Your display is set for the "ISO-8859-10" character set.  ]
    [ Some special characters may be displayed incorrectly. ]

On 9/6/07, Reuti <reuti at staff.uni-marburg.de> wrote:
> in SGE 6.1 it's fixed and supported by default.

Actually, you can get the support if you compile 6.1 from source and
pass -DHAS_AIX5_PERFLIB to aimk. Patching the code to the 6.0 source
tree should also be straightforward.

http://gridengine.sunsource.net/servlets/ReadMsg?list=cvs&msgNo=8329

The reason why it is not enabled in the pre-compiled binary on the
project page is that it's not sure whether libperfstat.a is available
on all the AIX 5.x versions. But at least it's available on my 5.2
box:

> lslpp -w /usr/lib/libperfstat.a
 File                                        Fileset               Type
 ----------------------------------------------------------------------------
 /usr/lib/libperfstat.a
                                       bos.perf.libperfstat        File

The advantage of using libperfstat API to get the load and memory info
is that users won't need to install the IBM load sensor after initial
installation. Also, execd could start as non-root but it is a less
major issue since most sites start SGE daemons as root anyways.

Rayson




>
> -- Reuti
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net




More information about the gridengine-users mailing list