[GE users] execd on HP-UX starts as root

Andy Schwierskott andy.schwierskott at sun.com
Fri Sep 14 10:46:05 BST 2007


Hi,

are you sure it's running as root or did you just look at the default "ps"
output?

By default the ps output on HP-UX prints the real uid, unlike on other OS'es
where you see the effective UID. The HP-UX ps(1) man page says:

            + The -u option will select users based on effective UID rather
              than real UID.

Andy

On Fri, 14 Sep 2007, truneaux wrote:

> Hi there,
>
> I have a newly installed 6.1u2 running and I just found that sgeexecd on HP-UX B11.11 on a 9000/785 running as root though there is an admin_user configured.
>
> The admin_user is qadmin, defined in a NIS passwd map. yppasswd gives me the same output an all platforms for qadmin, the $SGE_ROOT directory belongs to qadmin as well as everything below $SGE_ROOT but the sgeexecd keeps starting as root on these nodes. Only systems running HP-UX show this behaviour, the other plattforms don't.
>
> My qmaster runs on a Linux RHEL4, kernel 2.6.9-42.0.3, x86 architecture.
>
> Any suggestions ?
>
> Kind regards, Christian
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
> For additional commands, e-mail: users-help at gridengine.sunsource.net
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net




More information about the gridengine-users mailing list