[GE users] Job does not run on the other host.

amanyus amanyus at gmail.com
Sun Sep 16 03:49:51 BST 2007


During the linux x86 execd installation, qconf -sh returns:


error: sge_gethostbyname failed


After some checking, the qmaster on the main server is running and  
pingable.
Then I check the firewall which setting I never touch. Its default:


[root at linuxagent n1ge6]# iptables -L
Chain INPUT (policy ACCEPT)
target     prot opt source               destination
RH-Firewall-1-INPUT  all  --  anywhere             anywhere

Chain FORWARD (policy ACCEPT)
target     prot opt source               destination
RH-Firewall-1-INPUT  all  --  anywhere             anywhere

Chain OUTPUT (policy ACCEPT)
target     prot opt source               destination

Chain RH-Firewall-1-INPUT (2 references)
target     prot opt source               destination
ACCEPT     all  --  anywhere             anywhere
ACCEPT     icmp --  anywhere             anywhere            icmp any
ACCEPT     esp  --  anywhere             anywhere
ACCEPT     ah   --  anywhere             anywhere
ACCEPT     udp  --  anywhere             224.0.0.251         udp  
dpt:mdns
ACCEPT     udp  --  anywhere             anywhere            udp dpt:ipp
ACCEPT     tcp  --  anywhere             anywhere            tcp dpt:ipp
ACCEPT     all  --  anywhere             anywhere            state  
RELATED,ESTABLISHED
ACCEPT     tcp  --  anywhere             anywhere            state  
NEW tcp dpt:ssh
REJECT     all  --  anywhere             anywhere            reject- 
with icmp-host-prohibited



What could be the problem?


On Sep 16, 2007, at 9:35 AM, Rayson Ho wrote:

> You just need to unpack the x86 linux tarball in $SGE_ROOT.
>
> Rayson
>
>
>
> On 9/15/07, amanyus <amanyus at gmail.com> wrote:
>> Thanks alot guys! Now the jobs run on the other host.
>>
>> But now I need to add a x86 linux box which uses different binaries.
>> Since the mounted $SGE_ROOT only contain only sparc binaries, what is
>> the best way to place/untar the linux x86 binaries?
>>
>>
>> On Sep 13, 2007, at 2:25 PM, John Hearns wrote:
>>
>>> On Thu, 2007-09-13 at 04:01 +0800, amanyus wrote:
>>>> Among folders in $SGE_ROOT, which folder should be shared? Is it  
>>>> the
>>>> default (cell folder) must be shared?
>>>>
>>>> how do I install? Is it like this?
>>>>
>>>> 1. install qmaster on host A
>>>> 2. share $SGE_ROOT on host A
>>>> 3. mount remote $SGE_ROOT on host B
>>>> 4. install qmaster and execd on host B
>>>>
>>>> Steps 4 will show conflict because it will overwrite the default  
>>>> cell
>>>> contents. Right?
>>>>
>>>
>>> 4. install execd on host B
>>>
>>>
>>>
>>> Here I assume that host B will be an exec host - ie one of your
>>> compute
>>> hosts.
>>> If host B is to be a shadow master, you have to do things  
>>> differently.
>>>
>>> -------------------------------------------------------------------- 
>>> -
>>> To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
>>> For additional commands, e-mail: users-help at gridengine.sunsource.net
>>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
>> For additional commands, e-mail: users-help at gridengine.sunsource.net
>>
>>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
> For additional commands, e-mail: users-help at gridengine.sunsource.net
>

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net




More information about the gridengine-users mailing list