[GE users] queues duplicated in output from q commands

SLIM H.A. h.a.slim at durham.ac.uk
Thu Sep 27 11:38:23 BST 2007


Some two weeks ago the scheduler crashed. After restarting some queues
appear duplicate, for example the queue seq.q is attached twice to a
node:

qhost -q -h node097 -j
HOSTNAME                ARCH         NCPU  LOAD  MEMTOT  MEMUSE  SWAPTO
SWAPUS
------------------------------------------------------------------------
-------
global                  -               -     -       -       -       -
-
node097                 lx24-amd64      2  0.00    3.8G   52.4M   15.6G
9.6M
   seq.q                BP    2/2      
   seq.q                BP    2/2      d

(The queue in d state is probably the real one)

The output of qconf -sq seq.q gives the queue specification twice,
separated by a blank line. Applying qconf -mq seq.q, or, listing the
actual file in the cqueues directory shows the specification only once.
I assume the qconf -sq output is not generated from that file but is in
memory somewhere?

I tried to reload the queue file using qconf -Mq with a copy of the
queue specification file and the reply suggests that the queue is
modified but the duplicate queue has not gone. Do I need to restart the
qmaster to force rereading the queue files? (This 6.1u2)

Thanks for any help you can give

Henk

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net




More information about the gridengine-users mailing list