[GE users] Memory Leak in schedd 6.1u4?

Brian Smith brs at usf.edu
Sun Apr 6 19:06:22 BST 2008


Just restarted schedd with valgrind... I should have output the next 
time the oom_killer kicks in. Are the "retail" binaries built with 
debugging symbols or will I need to build my own schedd?

-Brian

Chris Dagdigian wrote:
> Hi Brian,
>
> People have been reporting schedd leaks in the 6.1u series - some 
> problems were found and fixed but there are indications on the user 
> list that the problem still remains. Multiple people have been trying 
> to track down the cause -- any additional eyeballs and details will 
> undoubtably be welcome, especially if you can run under valgrind or 
> other tools that may help trace down the offending code.
>
> -Chris
>
>
> On Apr 6, 2008, at 1:11 PM, Brian Smith wrote:
>> Has anyone else noticed a memory leak with 6.1u4? oom-killer is 
>> stopping my sge_schedd because its wolfing down gobs of ram. The box 
>> I'm running on has 4GB and is used only for nis, qmaster/schedd, and 
>> managing and provisioning the cluster. I'll post more details if 
>> desired.
>>
>>
>> Thanks,
>> -Brian
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
> For additional commands, e-mail: users-help at gridengine.sunsource.net


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net




More information about the gridengine-users mailing list