[GE users] TMPDIR issues

Craig Tierney Craig.Tierney at noaa.gov
Mon Apr 28 16:21:51 BST 2008


    [ The following text is in the "ISO-8859-1" character set. ]
    [ Your display is set for the "ISO-8859-10" character set.  ]
    [ Some special characters may be displayed incorrectly. ]

Brian Smith wrote:
> Hi all,
> 
> I suppose that for a parallel job, the execd of the MASTER "node" is 
> responsible for removing the TMPDIR of the job after it is done 
> executing.  Any idea what would case that directory to not get created 
> or to not be there when execd goes to clear it out?  I get a lot of 
> these sorts of messages and I think it might have something to do with 
> my bug #2393
> 
> 04/27/2008 10:03:49|execd|rcn-ib-0002|E|recursive 
> rmdir(/opt/sge/tmp/39038.1.rcnib.q): 
> opendir(/opt/sge/tmp/39038.1.rcnib.q) failed: No such file or directory
> 

Did you verify that job 39038 (or the other jobs with this problem) aren't
causing the problem?  Every once and awhile when a new user comes to our
system, their scripts are setup to create and cleanup a directory
which they name $TMPDIR.  This generally causes confusion between their job
and the system.  If your user has a script like this, and is cleaning up
$TMPDIR at the end of their script, Gridengine may return an error message
like the one you are seeing.

Craig




> Thanks,
> -Brian
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
> For additional commands, e-mail: users-help at gridengine.sunsource.net
> 
> 


-- 
Craig Tierney (craig.tierney at noaa.gov)

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net




More information about the gridengine-users mailing list