[GE users] Multiple problems with CSP installation

petrik lubomir.petrik at sun.com
Fri Dec 5 16:32:16 GMT 2008


Hi,
this might happen if your auto install template file doesn't have 
CSP_RECREATE defined or it's set to false.

Currently it MUST be set to true for the first time installation 
(CSP_RECREATE=true). Please reinstall the qmaster with updated template. 
Then the files under /var/sgeCA should be generated.

Regards,
   Lubos.

PS: And yes I'd consider this a bug. Please file an issue, if I'm right.

Prentice Bisbal wrote:
> I'm attempting to do an automated installation of GE 6.2 with CSP
> enabled. A previous installation a couple of days ago worked fine, and
> now I'm just trying to duplicate that installation with CSP enabled. I
> have encountered multiple problems. I installed a 5.3 system with CSP a
> few years ago w/o a single problem, but I also wasn't doing automated
> installs (very small cluster).
>
> Is CSP broken in 6.2?
>
> When I install the master, sge_execd won't start after an automatic
> install like this
>
> cd $SGE_ROOT
> ./inst_sge -csp -m -auto /path/to/file
>
> The log file shows an error like this:
>
> <quote>
>
> error: commlib error: can't set CA chain file
> (/var/sgeCA/port6444/default/userkeys/root/cert.pem)
> error: commlib error: ssl error ([ID=33558530] in module "system
> library": "No such file or directory")
> unable to send message to qmaster using port 6444 on host
> "aurora.sns.ias.edu": can't set CA chain file
>
> Command failed: ./bin/lx24-amd64/qconf -Ahgrp /tmp/hostqueue1215
>
> Probably a permission problem. Please check file access permissions.
> Check root read/write permission. Check if SGE daemons are running.
>
> </quote>
>
> I checked in /var/sgeCA, and found that the directory
> /var/sgeCA/port6444 doesn't even exist. Shouldn't it be created
> automatically?
>
> When do I do manual (interactive) install like this:
>
> cd SGE_ROOT
> ./install_qmaster -csp
>
> at the step where sge_execd starts, it takes a long time to start. In
> fact, I get an error that it didn't start, but it did eventually start,
> because I see sge_qmaster in the output of 'ps -ef'. Afterwards, i can
> stop/start sge_qmaster w/o a problem. This doesn't happen during a
> non-csp install.
>
> I also have problems automatically installing the execd nodes
> automatically. Again, this worked fine without the -csp option. The log
> file doesn't show anything useful.
>
> Am I doing something completely wrong? I did not copy /var/sgeCA over to
> all the exec hosts before running the install, but it's my understanding
> that the automatic install does this for me using scp.
>
>

------------------------------------------------------
http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=38&dsMessageId=91398

To unsubscribe from this discussion, e-mail: [users-unsubscribe at gridengine.sunsource.net].



More information about the gridengine-users mailing list