[GE users] installing sge master

reuti reuti at staff.uni-marburg.de
Sun Dec 14 18:04:36 GMT 2008


Hi,

Am 14.12.2008 um 18:52 schrieb Rafid Al-Khannak:

> Dear Prentice and all,
>
> thanks for the notes, they are very helpful and the command qconf  
> is working now
>
> --but about the qmon
>
> 1- when i wrote          qmon          the following message appears:
>
> qmon: error while loading shared libraries: libXm.so.3: cannot open  
> shared object file: No such file or directory
>
> 2- and when i wrote       ldd 'which qmon'       the following  
> message appears:

you will need backquotes here, not normal quotes:

$ ldd `which qmon`

> ldd: ./which qmon: No such file or directory
>
> about the first case i downloaded a package contains the libXm.so.3  
> and put it in /usr/X11R6/lib (as i did with the libXm.so.2,  
> libXm.so.2.1)
>
> but the same message always appear for the first case:
>
> qmon: error while loading shared libraries: libXm.so.3: cannot open  
> shared object file: No such file or directory

Is the location of the library in your LD_LIBRARY_PATH?

-- Reuti

>
>
> --also after i followed the notes that you gave me i wrote       ps  
> -ef | grep sge         and the output was:
>
> root      3307     1  0 17:33 ?        00:00:00 /home/sun/bin/lx24- 
> x86/sge_qmaster
> root      4135  4041  0 17:54 pts/2    00:00:00 grep sge
>
> does that mean the system is working properly? (because when i  
> checked the "Verifying the Installation" chaper it was almost the  
> same output but not exactly the same)
>
> and what about the qmon?
>
> regards,
> rafid
>
>
>
> 2008/12/12 Prentice Bisbal <prentice at ias.edu>
> Rafid Al-Khannak wrote:
> > dear all,
> >
> > after installing the master host (i faced some problems throught the
> > installation like sgemaster didn't start and the CSP cert didn't  
> copy to
> > the execution hosts but after the installation is finished i started
> > sgemaster without problems) i should write "qconf -sh" but this  
> message
> > appears "bash: qconf: command not found"
>
> That's because qconf isn't in your PATH yet, because you didn't source
> settings.sh correctly.
> >
> > also i entered this command "SGE_ROOT/default/common#./ 
> settings.sh" and
> > "SGE_ROOT/default/common#./settings.csh" and this message appears  
> "bash:
> > ./settings.sh: Permission denied"
> >
>
> There are a couple of mistakes in your commands. First you need to
> define SGE_ROOT properly. Assuming your shell is bash and you  
> installed
> SGE in /usr/local/sge, your commands should be this:
>
> SGE_ROOT=/usr/local/sge
> source $SGE_ROOT/default/common/settings.sh
>
> Notice I use the command "source" and that $SGE_ROOT has a "$" at the
> front of it, indicating that it SGE_ROOT is a variable.
>
> If you do that correctly, the qconf commands should work for you.
>
> > and from the verifying the installation i typed this command "ps - 
> ax |
> > grep sge" and the output was:
> >
> > Warning: bad ps syntax, perhaps a bogus '-'? See
> > http://procps.sf.net/faq.html
> > 32013 ?        Sl     0:00 /home/sun/bin/lx24-x86/sge_qmaster
> >   311 pts/0    R+     0:00 grep sge
>
> Wrong syntax of the 'ps' command. Try 'ps -ef | grep sge' instead.
> Please read the man page for 'ps'. It's a very useful tool if you know
> all the switches to it. You can read the man page with the command  
> 'man ps'
>
> >
> > also with the qmon when i wrote it under sge_root and under the  
> common:
> > SGE_ROOT/default/common # qmon
> > SGE_ROOT # qmon
> >
> > the output was:
> > bash: qmon: command not found
>
> Again, this is because you didn't source your settings.sh file
> correctly. If you follow the steps above, 'qmon' should work.
>
>
> --
> Prentice
>
> ------------------------------------------------------
> http://gridengine.sunsource.net/ds/viewMessage.do? 
> dsForumId=38&dsMessageId=92445
>
> To unsubscribe from this discussion, e-mail: [users- 
> unsubscribe at gridengine.sunsource.net].
>

------------------------------------------------------
http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=38&dsMessageId=92587

To unsubscribe from this discussion, e-mail: [users-unsubscribe at gridengine.sunsource.net].



More information about the gridengine-users mailing list