[GE users] installing sge master

Prentice Bisbal prentice at ias.edu
Mon Dec 15 16:27:54 GMT 2008


Rafid Al-Khannak wrote:
> Dear Prentice and all,
> 
> thanks for the notes, they are very helpful and the command qconf is
> working now
> 
> --but about the qmon
> 
> 1- when i wrote          qmon          the following message appears:
> 
> qmon: error while loading shared libraries: libXm.so.3: cannot open
> shared object file: No such file or directory

This is because you don't have Motif libraries installed. This is
covered in the Grid Engine Installation Guide:

http://wikis.sun.com/display/GridEngine/Other+Installation+Issues#OtherInstallationIssues-VerifyingandInstallingLinuxMotifLibraries

Your Linux distribution should provide OpenMotif packages that provide
the required motif libraries. For example, my RHEL-based distro has
these openmotif packages installed:

$ rpm -qa | grep openmotif
openmotif-2.3.0-0.5.el5
openmotif-devel-2.3.0-0.5.el5
openmotif22-2.2.3-18

I only really need one of them installed (openmotif22, I think), but I
installed them all for completeness, and to cover my a**, in case
another application needed a different version of the openmotif libraries.

Once you install the correct openmotif packages for your distro, qmon
should work fine.

-- 
Prentice

------------------------------------------------------
http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=38&dsMessageId=92705

To unsubscribe from this discussion, e-mail: [users-unsubscribe at gridengine.sunsource.net].



More information about the gridengine-users mailing list