[GE users] qrsh config?

Alex Chekholko chekh at pcbi.upenn.edu
Fri Dec 19 17:38:11 GMT 2008


Hi all,

This is SGE 6.1u3 on EL5.2 on x86_64.

I think the 'qrsh' command on my cluster doesn't work, and I'm trying
to figure out why.

I followed this guide:
http://gridengine.sunsource.net/howto/qrsh_qlogin_ssh.html

Users on our cluster use 'qlogin' when they want an interactive shell.
SGE chooses an available slot, connects to that node and drops the user
at the prompt.  That's working fine and always has.

I've never really used qrsh before and it does the following:

[chekh at beta.genomics.upenn.edu] ~/mpi [1] 
$ qrsh node-r2-u10-c25-p13-o6.local
error: error reading returncode of remote command
[chekh at beta.genomics.upenn.edu] ~/mpi [1] 
$ qrsh
[chekh at beta.genomics.upenn.edu] ~/mpi [1] 
$ qrsh uname -a
error: error reading returncode of remote command

If I type just "qrsh" it returns immediately with an error.  If I give
it any kind of argument, it takes a while.

Is the command "qrsh <nodename>" supposed to work?

[root at beta.genomics.upenn.edu] ~ [0] 
# qconf -sconf|grep ssh
qlogin_daemon                /usr/sbin/sshd -i
rlogin_daemon                /usr/sbin/sshd -i
rsh_daemon                   /usr/sbin/sshd -i
rsh_command                  /usr/bin/ssh -o StrictHostChecking=no
rlogin_command               /usr/bin/ssh -o StrictHostChecking=no
[root at beta.genomics.upenn.edu] ~ [0] 
# qconf -sconf node-r2-u10-c25-p13-o6.local
configuration node-r2-u10-c25-p13-o6.local not defined

Regards,
-- 
Alex Chekholko   chekh at pcbi.upenn.edu

------------------------------------------------------
http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=38&dsMessageId=93415

To unsubscribe from this discussion, e-mail: [users-unsubscribe at gridengine.sunsource.net].



More information about the gridengine-users mailing list