[GE users] sge_share_mon Issues

reuti reuti at staff.uni-marburg.de
Wed Dec 31 12:00:00 GMT 2008


Hiho,

Am 31.12.2008 um 07:55 schrieb templedf:

> I'm trying to extract information about the current share tree status
> using sge_share_mon, and I'm running into some issues.  First, the
> job_count field is always zero.  I haven't looked at the scheduler
> source code yet, but I suspect it's because that field is no longer
> used.  Can anyone deny or confirm?  Also, in my configuration, the
> halflife_decay_list is cpu=-1:mem=-1:io=-1, so for me the actual_share
> field only contains information about the jobs scheduled during the  
> last
> scheduler run.  The long and short target_share fields don't appear to
> be doing much of anything.  All I really need is an accurate
> actual_share for my share tree nodes.  If the job_count worked, I  
> could
> calculate the actual share.  As is, it's looking like my only
> alternative is to do some really ugly qstat processing.  Anyone have
> clever suggestions?

you have running jobs in the cluster?

There was a similar issue a couple of month ago: http:// 
gridengine.sunsource.net/ds/viewMessage.do? 
dsForumId=38&dsMessageId=16161 which was never solved. For me,  
sometimes all entries show sensibale values, and sometimes I can't  
get a clue, why several fields are zero.

-- Reuti

------------------------------------------------------
http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=38&dsMessageId=94992

To unsubscribe from this discussion, e-mail: [users-unsubscribe at gridengine.sunsource.net].



More information about the gridengine-users mailing list