[GE users] Troubles with Interix and AD

Beadles, Jeff jeff_beadles at mentor.com
Fri Jan 25 20:01:13 GMT 2008


I'm no windows expert, but here we do this by logging into the host as
the local administrator by;

$ telnet mypc
Trying 1.2.3.4...
Connected to mypc.
Escape character is '^]'.

Interix 3.5 (mypc) (ttyp0)
NOTE:
   The default NT Domain used during login is identified within
   the parentheses of the login prompt below "(MYDOMAIN)".
   If there is no default value or if you want to login using a
   different NT Domain then ensure that a Domain name is prefixed
   to the login name in the form of  DomainName+loginName

(MYDOMAIN) login: mypc+administrator
Password: ...

Copyright (c) Microsoft Corporation.  All rights reserved.
Welcome to the Interix UNIX utilities.
DISPLAY=localhost:0.0

$ id
uid=197108(mypc+Administrator) gid=197121(mypc+None)
groups=197121(mypc+None), 65792(+Everyone), 131616(+Administrators),
131617(+Users), 66820(+INTERACTIVE), 66827(+Authenticated Users),
4095(CurrentSession), 66048(+LOCAL)
$ su jeffb
$ id
uid=1055726(jeffb) gid=1049089(Domain Users) groups=1049089(Domain
Users), ...

Does that work for you?

	-Jeff
-- 
Jeff Beadles, Mentor Graphics Corporation - jeff_beadles zat mentor.com


-----Original Message-----
From: Beat Rubischon [mailto:beat at 0x1b.ch] 
Sent: Friday, January 25, 2008 11:48 AM
To: Grid Engine Users
Subject: [GE users] Troubles with Interix and AD

Hello!

Last week, I deployed a W2k3 server running SGE in production
environment.
While the system runs OK in my test environment, I have some troubles
with
the Active Directory setup.

In a Interix shell, als local Administrator, I'm not able to setuid to
an
unpriviledged user:

    $ id
    uid=197108(LOCAL+Administrator) ...

    $ su luserl
    su: setuser: Permission denied
    Sorry 

But I'm able to become domain administrator - this works also for some
priviledged users:

    $ su Administrator
    $ id
    uid=1049076(Administrator) ...

The Grid Engine Execution Daemon isn't happy with this situation, dies
away
and the queue goes into Error state.

I'm quite sure there is a checkbox in the users dialog of the Active
Directory management screen which is needed to be able to become such a
user
in a batch environment. Somebode here who has an idea which flag is
needed?

Beat

-- 
     \|/                           Beat Rubischon <beat at 0x1b.ch>
   ( 0^0 )                             http://www.0x1b.ch/~beat/
oOO--(_)--OOo---------------------------------------------------
Meine Erlebnisse, Gedanken und Traeume: http://www.0x1b.ch/blog/



---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net




More information about the gridengine-users mailing list