[GE users] maui does not work with sge

Ron Chen ron_chen_123 at yahoo.com
Wed Jul 9 23:09:52 BST 2008


Are there any specific features that you need from Maui?

SGE added advanced reservation in SGE 6.2, so most sites that wanted to use Maui+SGE can now use SGE6.2 instead.

http://gridengine.sunsource.net/nonav/source/browse/~checkout~/gridengine/doc/devel/rfe/AdvanceReservationSpecification.html

 -Ron


--- On Thu, 7/10/08, Brian O'Connor <briano at sgi.com> wrote:
> From: Brian O'Connor <briano at sgi.com>
> Subject: [GE users] maui does not work with sge
> To: mauiusers at supercluster.org
> Cc: users at gridengine.sunsource.net
> Date: Thursday, July 10, 2008, 5:28 AM
> Anybody got sge 6x and maui 3.2.6p19 to work?
>  
> Its driving me crazy.... 
>  
> I ahve followed the instructions 
>  
> http://www.clusterresources.com/products/maui/docs/sgeintegration.shtml
>  
> sge works, torque/maui works, I have recompiled maui with
> sge. I have
> used a 
> basic maui.cfg;
> cat maui.cfg
>  
> # maui.cfg 3.2.6p19
> SERVERHOST            mel-dem1.melbourne.sgi.com
> # primary admin must be first in list
> ADMIN1                root
> # Resource Manager Definition
> RMCFG[mel-dem1.melbourne.sgi.com] TYPE=SGE
> AMCFG[bank]  TYPE=NONE
> RMPOLLINTERVAL        00:00:30
> SERVERPORT            42559
> SERVERMODE            NORMAL
> LOGFILE               maui.log
> LOGFILEMAXSIZE        10000000
> LOGLEVEL              9
>  
> thats it!. The config works with torque, but maui does not
> seem to see
> sge at all.
> I am not using any strange ports etc (701 for sge_qmaster)
> The logs say;
> 07/10 07:05:24 ALERT:    cannot load cluster resources on
> RM (RM
> 'mel-dem1.melbourne.sgi.com' does not support
> function 'clusterquery')
> 07/10 07:05:24 WARNING:  no resources detected
> 07/10 07:05:24 MRMWorkloadQuery()
> 07/10 07:05:24 ALERT:    cannot load cluster workload on RM
> (RM
> 'mel-dem1.melbourne.sgi.com' does not support
> function 'workloadquery')
> 07/10 07:05:24 WARNING:  no workload detected
>  
> followed by lots of
>  
> 07/10 07:05:24 ALERT:    cannot query events on RM (RM
> 'mel-dem1.melbourne.sgi.com' does not support
> function 'rmeventquery')
> 07/10 07:05:24 MSUAcceptClient(5,ClientSD,HostName,TCP)
> 07/10 07:05:24 INFO:     accept call failed, errno: 11
> (Resource
> temporarily unavailable)
> 07/10 07:05:24 INFO:     all clients connected.  servicing
> requests
> 07/10 07:05:24 MRMCheckEvents()
> 
>  
> 
> and showq is empty
> 
> Google shows me some questions be no answers. 
> 
> I am starting to think that this only works with SGE 5.3!
> 
> Anybody using 6x?
> 
>  
> 
>  
> 
> Brian O'Connor
> -----------------------------------------------------------------------
> SGI Consulting
> Email: briano at sgi.com, Mobile +61 417 746 452
> Phone: +61 3 9963 1900, Fax:  +61 3 9963 1902
> 357 Camberwell Road, Camberwell, Victoria, 3124
> AUSTRALIA
> http://www.sgi.com/support/services
> -----------------------------------------------------------------------


      

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net




More information about the gridengine-users mailing list