[GE users] Computer with two NIC problem

Reuti reuti at Staff.Uni-Marburg.DE
Fri Jul 18 16:29:02 BST 2008


Am 18.07.2008 um 16:04 schrieb Fedele STABILE:

> First of all:
> this two hosts are part of different cluster

What does this mean in detail: you will have two sgeexecd's running  
as they are part of two clusters? Then you need different ports for  
the qmaster and execd services, and a different location of the  
"common" directory per cluster - therefor the "cell-name" in SGE. If  
you want to use the same SGE installation for two cluster, you will  
have to use also two different "cell-names".

-- Reuti


> Now these are /etc/hosts :
> on telesioms-ext1
>
> 127.0.0.1       localhost
> 10.128.101.1    telesioms rmshost  <<< on NIC_B (private)
> 160.97.1.27     telesioms-ext1          telesioms- 
> ext1.fis.unical.it <<<
> on NIC_A (public LAN)
> 160.97.1.3      plasmi.fis.unical.it    plasmi
>
> on plasmi
>
> 127.0.0.1       localhost.localdomain   localhost
> 160.97.1.3      plasmi.fis.unical.it    plasmi <<< on NIC_A (public  
> LAN)
> 192.168.0.1     pc0.plasmi.cluster      pc0 <<< on NIC_B (private)
> 160.97.1.27     telesioms-ext1.fis.unical.it    telesioms-ext1
>
> act_master contains
> plasmi.fis.unical.it
> CELL name is PLASMI
> and $SGE_ROOT/PLASMI is a networked filesystem
>
> on telesioms-ext1
> # cd /usr/local/GridEngine/GE-6/utilbin/tru64
> # ./gethostbyname -aname telesioms
> telesioms-ext1.fis.unical.it
> # ./gethostbyname -aname telesioms-ext1
> telesioms-ext1
> # ./gethostbyname -aname telesioms-ext1.fis.unical.it
> telesioms-ext1
> # ./gethostbyname -aname pc0
> error resolving host "pc0": can't resolve host name (h_errno =
> HOST_NOT_FOUND)
>
> on plasmi
>
> # cd /usr/local/GridEngine/GE-6/utilbin/lx24-x86
> [root at plasmi lx24-x86]# ./gethostbyname -aname plasmi
> critical error: Please set the environment variable SGE_ROOT.
> [root at plasmi lx24-x86]#
> source /usr/local/GridEngine/GE-6/PLASMI/common/settings.sh
> [root at plasmi lx24-x86]# ./gethostbyname -aname plasmi
> plasmi.fis.unical.it
> [root at plasmi lx24-x86]# ./gethostbyname -aname plasmi.fis.unical.it
> plasmi.fis.unical.it
> [root at plasmi lx24-x86]# ./gethostbyname -aname pc0
> pc0.plasmi.cluster
> [root at plasmi lx24-x86]# ./gethostbyname -aname telesioms
> error resolving host "telesioms": can't resolve host name (h_errno =
> HOST_NOT_FOUND)
> [root at plasmi lx24-x86]# ./gethostbyname -aname telesioms-ext1
> telesioms-ext1.fis.unical.it
>
>
> Il giorno ven, 18/07/2008 alle 14.25 +0200, Reuti ha scritto:
>> Am 18.07.2008 um 14:18 schrieb Fedele STABILE:
>>
>>> Yes i read this document and i modified host_aliases .
>>>
>>> Another hint is this output:
>>> # qstat -explain a
>>> queuename                      qtype used/tot. load_avg arch
>>> states
>>> -------------------------------------------------------------------- 
>>> --
>>> ------
>>> prova at telesioms-ext1.fis.unica BIP   0/1       -NA-     -
>>> NA-          au
>>>         error: no value for "np_load_avg" because execd is in  
>>> unknown
>>> state
>>>
>>> but telesioms-ext1 port 537 (the sge_execd) is opened and daemon is
>>> running.
>>
>> Can you please post the relevant lines of /etc/hosts (which of them
>> is the primary interface?) of both machine and the content of
>> $SGE_ROOT/default/common/act_qmaster.
>>
>> -- Reuti
>>
>>
>>> Fedele
>>>
>>> Il giorno ven, 18/07/2008 alle 13.07 +0200, Reuti ha scritto:
>>>> Hi,
>>>>
>>>> - the two network cards have different names in /etc/hosts on each
>>>> machine, so that one name is pointing unambiguously to one  
>>>> interface
>>>> only?
>>>>
>>>> - you read http://gridengine.sunsource.net/howto/ 
>>>> multi_intrfcs.html?
>>>>
>>>> -- Reuti
>>>>
>>>>
>>>> Am 18.07.2008 um 12:50 schrieb Fedele STABILE:
>>>>
>>>>> Hello to all,
>>>>>
>>>>> i have a problem with two PC, each one has 2 NIC (ex. NIC_A and
>>>>> NIC_B)
>>>>> and NIC_A is in the same network.
>>>>>
>>>>> I whold like configure SGE to pubblish informations only on NIC_A.
>>>>>
>>>>> I'm trying with  host_aliases
>>>>> but i'm not lucky
>>>>>
>>>>> this is my host_aliases:
>>>>>
>>>>> telesioms-ext1.fis.unical.it    telesioms
>>>>> plasmi.fis.unical.it            pc0
>>>>>
>>>>> (the first column is NIC_A hostname and second column is NIC_B
>>>>> hostname
>>>>>
>>>>> if i run qstat -f
>>>>>
>>>>> this is the output:
>>>>>
>>>>>
>>>>> # qstat -f
>>>>> queuename                      qtype used/tot. load_avg arch
>>>>> states
>>>>> ------------------------------------------------------------------ 
>>>>> --
>>>>> --
>>>>> ------
>>>>> prova at telesioms-ext1.fis.unica BIP   0/1       -NA-     -
>>>>> NA-          au
>>>>> ------------------------------------------------------------------ 
>>>>> --
>>>>> --
>>>>> ------
>>>>> prova2 at plasmi.fis.unical.it    BIP   0/1       -NA-     -
>>>>> NA-          au
>>>>>
>>>>> Any suggestion?
>>>>>
>>>>> Fedele STABILE
>>>>>
>>>>>
>>>>> ------------------------------------------------------------------ 
>>>>> --
>>>>> -
>>>>> To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
>>>>> For additional commands, e-mail: users- 
>>>>> help at gridengine.sunsource.net
>>>>
>>>>
>>>> ------------------------------------------------------------------- 
>>>> --
>>>> To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
>>>> For additional commands, e-mail: users- 
>>>> help at gridengine.sunsource.net
>>>>
>>>
>>>
>>> -------------------------------------------------------------------- 
>>> -
>>> To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
>>> For additional commands, e-mail: users-help at gridengine.sunsource.net
>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
>> For additional commands, e-mail: users-help at gridengine.sunsource.net
>>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
> For additional commands, e-mail: users-help at gridengine.sunsource.net


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net




More information about the gridengine-users mailing list