[GE users] Help: OpenMPI Integration Problem

Reuti reuti at staff.uni-marburg.de
Fri May 23 12:10:49 BST 2008


Hi,

Am 23.05.2008 um 07:47 schrieb Lee Amy:

> I make an OpenMPI tight integration parallel environment. I'm sure  
> that I've enabled gridengine support for OpenMPI 1.2.6. However,  
> when I submit job script the qstat shows the task is runing, but  
> the program which is in script dosen't run any more.
>
> Now I will paste the relative files.
>
> Parallel Environment
> ######
> pe_name           openmpi
> slots             20
> user_lists        NONE
> xuser_lists       NONE
> start_proc_args   /bin/true
> stop_proc_args    /bin/true
> allocation_rule   $round_robin
> control_slaves    FALSE
> job_is_first_task TRUE

control_slaves  TRUE
job_is_first_task  FALSE

http://www.open-mpi.org/faq/?category=running#run-n1ge-or-sge

Be aware, that from 1.3 on you have to request it explicitly during  
configure.

-- Reuti


> urgency_slots     min
> ######
>
> Job Script
> ######
> #!/bin/bash
>
> /usr/local/openmpi/bin/mpirun --mca pls_agent_rsh rsh -np $NSLOTS / 
> usr/local/clustalw-mpi/clustalw-mpi -infile=/usr/local/test/2000
> ######
>
> Error Output
> ######
> error: executing task of job 5 failed:
> [gnode4:15774] ERROR: A daemon on node gnode1 failed to start as  
> expected.
> [gnode4:15774] ERROR: There may be more information available from
> [gnode4:15774] ERROR: the 'qstat -t' command on the Grid Engine tasks.
> [gnode4:15774] ERROR: If the problem persists, please restart the
> [gnode4:15774] ERROR: Grid Engine PE job
> [gnode4:15774] ERROR: The daemon exited unexpectedly with status 1.
> error: executing task of job 5 failed:
> [gnode4:15774] ERROR: A daemon on node gnode2 failed to start as  
> expected.
> [gnode4:15774] ERROR: There may be more information available from
> [gnode4:15774] ERROR: the 'qstat -t' command on the Grid Engine tasks.
> [gnode4:15774] ERROR: If the problem persists, please restart the
> [gnode4:15774] ERROR: Grid Engine PE job
> [gnode4:15774] ERROR: The daemon exited unexpectedly with status 1.
> error: executing task of job 5 failed:
> [gnode4:15774] ERROR: A daemon on node gnode3 failed to start as  
> expected.
> [gnode4:15774] ERROR: There may be more information available from
> [gnode4:15774] ERROR: the 'qstat -t' command on the Grid Engine tasks.
> [gnode4:15774] ERROR: If the problem persists, please restart the
> [gnode4:15774] ERROR: Grid Engine PE job
> [gnode4:15774] ERROR: The daemon exited unexpectedly with status 1.
> ######
>
> Shall I configure anything else?
>
> Thank you very much~
>
> Regards,
>
> Amy Lee


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net




More information about the gridengine-users mailing list