[GE users] Problem compiling sge V62

goncalo goncalo at lip.pt
Wed Nov 12 18:30:38 GMT 2008


    [ The following text is in the "UTF-8" character set. ]
    [ Your display is set for the "ISO-8859-10" character set.  ]
    [ Some characters may be displayed incorrectly. ]

Hi All...

I'm having problems compiling sge V62 from source in SL4. This is not 
the first time I do this kind of work but the procedures I used to 
compile sge V6.1u3 seem to have changed, and no longer work for V62. At 
a given point of the compilation, it aborts with the following error:

(...)
gcc -O3 -Wall -Werror -Wstrict-prototypes -D__GRIDENGINE_FD_SETSIZE=8192 
-DLINUX -DLINUX86 -DLINUX86_26 -D_GNU_SOURCE -DGETHOSTBYNAME_R6 
-DGETHOSTBYADDR_R8  -DHAS_IN_PORT_T -DLOAD_OPENSSL -I/include/ 
-DSGE_ARCH_STRING=lx26-x86 -DTARGET_32BIT  -DSPOOLING_dynamic -DSECURE 
-I/usr/share/ssl/include -Wno-strict-aliasing -D_FILE_OFFSET_BITS=64 
-DCOMPILE_DC -D__SGE_COMPILE_WITH_GETTEXT__  -D__SGE_NO_USERMAPPING__ 
-I../common -I../libs -I../libs/uti -I../libs/juti -I../libs/gdi 
-I../libs/japi -I../libs/sgeobj -I../libs/cull -I../libs/rmon 
-I../libs/comm -I../libs/comm/lists -I../libs/sched -I../libs/evc 
-I../libs/evm -I../libs/mir -I../libs/lck -I../daemons/common 
-I../daemons/qmaster -I../daemons/execd -I../daemons/schedd 
-I../clients/common -I. -I/usr/java/jdk1.5.0_16/include 
-I/usr/java/jdk1.5.0_16/include/linux -Wno-strict-prototypes -fPIC 
-ULOAD_OPENSSL -c ../libs/comm/cl_ssl_framework.c -o 
cl_ssl_framework_static.o
../libs/comm/cl_ssl_framework.c: In function 
`cl_com_ssl_build_symbol_table':
../libs/comm/cl_ssl_framework.c:1861: warning: assignment from 
incompatible pointer type
../libs/comm/cl_ssl_framework.c:1883: warning: assignment from 
incompatible pointer type
../libs/comm/cl_ssl_framework.c:1884: warning: assignment from 
incompatible pointer type
../libs/comm/cl_ssl_framework.c:1885: warning: assignment from 
incompatible pointer type
../libs/comm/cl_ssl_framework.c:1886: warning: assignment from 
incompatible pointer type
../libs/comm/cl_ssl_framework.c:1887: warning: assignment from 
incompatible pointer type
../libs/comm/cl_ssl_framework.c:1890: warning: assignment from 
incompatible pointer type
../libs/comm/cl_ssl_framework.c:1893: warning: assignment from 
incompatible pointer type
../libs/comm/cl_ssl_framework.c:1896: warning: assignment from 
incompatible pointer type
../libs/comm/cl_ssl_framework.c:1897: warning: assignment from 
incompatible pointer type
make: *** [cl_ssl_framework_static.o] Error 1

It seems related to some missing ssl feature but I have the default ssl 
packages offered by the  SL4 distribution installed:

 [root at ui02 source]# rpm -qa | grep ssl
openssl-devel-0.9.7a-43.17.el4_6.1
xmlsec1-openssl-1.2.6-3
openssl-0.9.7a-43.17.el4_6.1

Are these the right versions or I'm missing something?

Another less important issue is that ./aimk has to be run with the 
"-no-dump" because libcore.so doesn't exist.

[root at ui02 source]# ./aimk
error: couldn't find  /usr/lib/libcore.so
error: please
error: (a) get you a libcore.so for lx26-x86 from
error: http://gridengine.sunsource.net/issues/show_bug.cgi?id=2552
error: update CORE_HOME in aimk.site or aimk.private accordingly
error: (b) use aimk option -no-dump to build without libcore.so

I would set the defaults the other way around...

Cheers
Gon?alo

------------------------------------------------------
http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=38&dsMessageId=88642

To unsubscribe from this discussion, e-mail: [users-unsubscribe at gridengine.sunsource.net].



More information about the gridengine-users mailing list