[GE users] DRMAA version conflicts

Girndt, Lars (Lineas; ADITG/DFG) lgirndt at de.adit-jv.com
Fri Nov 14 10:07:13 GMT 2008


Hi all,

I facing a quite confusing problem with the Java DRMAA Binding. 

We are developing an application for a customer, which submits tasks via
DRMAA. We have GE 6.1u5 in our development environment, the customer
believes he has GE 6.1u3 (for instance qstat -help prints out this
version).

It seems that the signatures of org.ggf.drmaa.JobTemplate in
$SGE_ROOT/lib/drama.jar differ in the jar of their version of the SGE
and ours.

javap says for our GE 6.1u5:

public class org.ggf.drmaa.JobTemplate extends java.lang.Object{
...
public void setArgs(java.lang.String[])
...
}

For our customer it is:

public interface org.ggf.drmaa.JobTemplate{
...
public abstract void setArgs(java.util.List)
...
}

There are 2 significant changes: In one version JobTemplate is a proper
class, in the other version just an interface, and the signature has
changed from List to an array.

But I already used GE 6.0u8 (if I remember correctly) with the same code
as I do now and I cannot remember that I had to change something due to
interface changes.

My assumption is, that the customer's environment is not correctly
installed (there are many other hints for that).

Can somebody clearly say between which versions these interface changes
occurred so I have a strong evidence for my assumption?

Best regards,

Lars Girndt

------------------------------------------------------
http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=38&dsMessageId=88734

To unsubscribe from this discussion, e-mail: [users-unsubscribe at gridengine.sunsource.net].



More information about the gridengine-users mailing list