[GE users] group resource quota

reuti reuti at staff.uni-marburg.de
Wed Nov 19 14:22:00 GMT 2008


Am 19.11.2008 um 11:27 schrieb andreas:

> On Tue, 18 Nov 2008, reuti wrote:
>
>> Am 18.11.2008 um 17:48 schrieb andreas:
>>
>>> On Tue, 18 Nov 2008, brs wrote:
>>>
>>>> Hi, Reuti,
>>>>
>>>> How about another example:
>>>>
>>>> Say I want to limit vmem usage for all users on any host to, say,
>>>> 95% of
>>>> the physical memory available (not exactly how I would set it  
>>>> up, but
>>>> you get the idea).  Could I accomplish this like so?
>>>>
>>>> {
>>>>   name         vmem_limit
>>>>   description  "Limit users to only 95% of total physical memory
>>>> to avoid \
>>>>   swaping"
>>>>   enabled      FALSE
>>>>   limit        hosts {*} to h_vmem=$mem_total*0.95
>>>> }
>>>>
>>>> And how would this limit manifest itself?  Would the first job that
>>>> tried to allocate more than the quota allows bomb on a malloc() or
>>>> something?  Is this even possible within the rqs or should I  
>>>> just use
>>>> limits.conf?
>>>
>>> This does not (yet) work. Reason is that resource quota limits are
>>> not enforced as resource limits. If they were malloc()
>>> would return NULL once the quota is exceeded.
>>
>> And the reason is not, that it's only working (the formula) for INT
>> and DOUBLE?
>
> No. It's because resource limitations that would stem from RQS are
> simply disregarded with the 'math exercise' that is done right before
> job delivery from qmaster to execd.

Then I would suggest to add this to the documentation. It states only  
DOUBLE and INT as allowed complexes, but not MEMORY (man  
sge_resource_quota).

>> I just tried it, and the RQS seems simply to be ignored when I
>> request -l h_vmem with the above RQS in place. Jobs get scheduled
>> although they shouldn't.
>
> Hmmmmm. Should be a different problem. Above I see it in
> disabled state. Could it be that you forgot to enable it?

Argh, right - I just copied the above lines :-/

-- Reuti

> Note, I ran a quick test with the very same RQS using a job that  
> requests 10G like this
>
>    qsub -l h_vmem=10G -b y /bin/sleep 5
>
> it gets me
>
>     Job cannot run because it exceeds limit "////morfin/" in rule  
> "vmem_limit/1"
>
> as 'scheduling info' when I run qstat -j <jobid> in a 6.1u5  
> installation with 'morfin' having 8G as total_mem.
>
> Regards,
> Andreas
>
> Sitz der Gesellschaft: Sun Microsystems GmbH, Sonnenallee 1,  
> D-85551 Kirchheim-Heimstetten
> Amtsgericht Muenchen: HRB 161028
> Geschaeftsfuehrer: Thomas Schroeder, Wolfgang Engels, Dr. Roland  
> Boemer
> Vorsitzender des Aufsichtsrates: Martin Haering
>
> ------------------------------------------------------
> http://gridengine.sunsource.net/ds/viewMessage.do? 
> dsForumId=38&dsMessageId=89051
>
> To unsubscribe from this discussion, e-mail: [users- 
> unsubscribe at gridengine.sunsource.net].

------------------------------------------------------
http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=38&dsMessageId=89110

To unsubscribe from this discussion, e-mail: [users-unsubscribe at gridengine.sunsource.net].



More information about the gridengine-users mailing list