[GE users] question concerning R on HPC

andreas andreas.haas at sun.com
Tue Nov 25 17:12:14 GMT 2008


On Tue, 25 Nov 2008, Rainer M Krug wrote:

> On Tue, Nov 25, 2008 at 5:15 PM, andreas <andreas.haas at sun.com> wrote:
>> Hi Rainer,
>>
>> On Tue, 25 Nov 2008, Dr. Rainer M Krug wrote:
>>
>>> -----BEGIN PGP SIGNED MESSAGE-----
>>> Hash: SHA1
>>>
>>> Hi
>>>
>>> I want to use R on an HPC via MPI.
>>>
>>> I managed to install Rmpi and to load it ionto R, but I get the
>>> following errormessage when I try to create an MPI cluster and R hangs
>>> (no response):
>>>
>>> library(Rmpi)
>>> [head001:15781] mca: base: component_find: unable to open osc pt2pt:
>>> file not found (ignored)
>>>> library(snow)
>>>> cl <- makeCluster(2, type = "MPI")
>>> Rscript execution error: No such file or directory
>>> Rscript execution error: No such file or directory
>>
>> try to run this under Linux strace(1) as to trace the system calls.
>> This will show you what file/directory your application tries to access.
>
> I tried this, but the output is HUGE and I don't know what I should be
> looking for.

"No such file or directory" stands for the ENOENT as errno upon 
open()/fopen() failures. So you must look in the strace(1) output 
for a open()/fopen() that returns -1/NULL as error indication. 
Once you have the open()/fopen() you know also which file Rmpi 
tried to access.

Regards,
Andreas

http://gridengine.info/

Sitz der Gesellschaft: Sun Microsystems GmbH, Sonnenallee 1, D-85551 Kirchheim-Heimstetten
Amtsgericht Muenchen: HRB 161028
Geschaeftsfuehrer: Thomas Schroeder, Wolfgang Engels, Dr. Roland Boemer
Vorsitzender des Aufsichtsrates: Martin Haering

------------------------------------------------------
http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=38&dsMessageId=89805

To unsubscribe from this discussion, e-mail: [users-unsubscribe at gridengine.sunsource.net].



More information about the gridengine-users mailing list