[GE users] qrsh_starter/shepherd problems?

reuti reuti at staff.uni-marburg.de
Tue Nov 25 18:07:26 GMT 2008


Am 25.11.2008 um 18:44 schrieb Harry Mangalam:

> I'm struggling get the various qrsh, qsh, qlogin commands working as
> well.  Given the bug that Harald cites, what is the recommended way
> to set up the global config.
>
> I was trying to use ssh for everything:
>
> qlogin_command               /usr/bin/ssh
> qlogin_daemon                /usr/sbin/sshd -i
> rlogin_command               /usr/bin/ssh -Y
> rlogin_daemon                /usr/sbin/sshd -i
> rsh_command                  /usr/bin/ssh -Y
> rsh_daemon                   /usr/sbin/sshd -i

http://gridengine.sunsource.net/howto/qrsh_qlogin_ssh.html

or

http://gridengine.sunsource.net/ds/viewMessage.do? 
dsForumId=38&dsMessageId=89685

> but under this config:
> - qrsh works well (user will be connected to an execution node and be
> able to view X11 apps - critical to our usage model),
>
> - qsh doesn't work:
> $ qsh
> Your job 57 ("INTERACTIVE") has been submitted
> waiting for interactive job to be scheduled ...
> Could not start interactive job.

This will not work, as it's using a plain TCP connection and you  
would need "xhosts +" and switch the firewall off on ports 6000+.  
Nowadays this is not recommended.

http://gridengine.sunsource.net/ds/viewMessage.do? 
dsMessageId=65347&dsForumId=38

But you can use with the above ssh setup: qrsh xterm

-- Reuti


> - qlogin doesn't work
>  $ qlogin
> local configuration bduc-login.nacs.uci.edu not defined - using global
> configuration
> Your job 58 ("QLOGIN") has been submitted
> waiting for interactive job to be scheduled ...
> Your interactive job 58 has been successfully scheduled.
> Establishing /usr/bin/ssh session to host bduc-i32-9.bduc ...
> bash: 42788: command not found
> /usr/bin/ssh exited with exit code 127
>
> it looks like there is some kind of parameter passing problem going on
> where the '42788' above is some kind of internal process?  It doesn't
> seem to be related to the PID on the submitting host.  I saw mention
> of a wrapper function somewhere, but I can't find it anymore.
>
> Harry
>
>
> On Monday 24 November 2008, pollinger wrote:
>> Please have a look at
>> http://gridengine.sunsource.net/issues/show_bug.cgi?id=2775
>>
>> It seems to be this bug. This bug can only occur with the "builtin"
>> mechanism.
>>
>> Regards,
>> Harald
>
>
>
> -- 
> Harry Mangalam - Research Computing, NACS, E2148, Engineering Gateway,
> UC Irvine 92697  949 824-0084(o), 949 285-4487(c)
>
> ------------------------------------------------------
> http://gridengine.sunsource.net/ds/viewMessage.do? 
> dsForumId=38&dsMessageId=89808
>
> To unsubscribe from this discussion, e-mail: [users- 
> unsubscribe at gridengine.sunsource.net].

------------------------------------------------------
http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=38&dsMessageId=89811

To unsubscribe from this discussion, e-mail: [users-unsubscribe at gridengine.sunsource.net].



More information about the gridengine-users mailing list