[GE users] NULL object pointer

Olesen, Mark Mark.Olesen at emcontechnologies.com
Wed Oct 8 13:54:00 BST 2008


> > As originally suspected, the problem was indeed
> > non-GridEngine related.
> > There was a very stringent umask setting that leaked
> > through the script to the qconf call and annoyed it :(
> 
> Good that it's resolved now!
> 
> Can you describe how one can reproduce it? We may want to see if it
> needs to be fixed or avoided -- just to make SGE more robust in all
> kinds of environments.

This is the easy way to reproduce the problem:

#!/bin/sh
umask 0222
qconf -mattr exechost complex_values license=1 global
exit $?

Writing the two operations so close together certainly makes it easier
to spot the problem than when they are sourced separately from
elsewhere!

/mark
This e-mail message and any attachments may contain 
legally privileged, confidential or proprietary Information, 
or information otherwise protected by law of EMCON 
Technologies, its affiliates, or third parties. This notice 
serves as marking of its "Confidential" status as defined 
in any confidentiality agreements concerning the sender 
and recipient. If you are not the intended recipient(s), 
or the employee or agent responsible for delivery of this 
message to the intended recipient(s), you are hereby 
notified that any dissemination, distribution or copying 
of this e-mail message is strictly prohibited. 
If you have received this message in error, please 
immediately notify the sender and delete this e-mail 
message from your computer.


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net




More information about the gridengine-users mailing list