[GE users] ArCo installation

Miguel Dias Costa mcosta at fc.up.pt
Mon Oct 13 11:49:34 BST 2008


    [ The following text is in the "UTF-8" character set. ]
    [ Your display is set for the "ISO-8859-10" character set.  ]
    [ Some characters may be displayed incorrectly. ]

Hello

Jana Olivova wrote:
> Hi
>
> Try this step:
>
> http://wikis.sun.com/display/GridEngine/ARCo+Troubleshooting#ARCoTroubleshooting-Problem%3ANoapplicationisregisteredwiththisSunJava%28TM%29WebConsole%2Coryouhavenorightstouseanyapplicationsthatareregistered. 
>
>
> I think it is related to this issue:
> http://gridengine.sunsource.net/issues/show_bug.cgi?id=2696
thanks, but it didn't work. If I uninstal everything and then (as root):

- unpack webconsole3.0.2-linux.tar.gz
- run ./setup -n
<...> Installlation complete.
- smcwebserver start
Starting Sun Java(TM) Web Console Version 3.0.2 ...
Exception while starting container instance console: An exception was 
thrown while executing /var/opt/webconsole/domains/console/conf/wcstart 
nobody

this seems to be because wcstart does not have execute permission, maybe 
something else failed too.

If I do "chmod +x /var/opt/webconsole/domains/console/conf/wcstart", 
then smcwebserver starts, but the output of "wcadmin list" already shows 
the "administration privileges" problem, before trying to install arco:

"
Must have administration privileges to list deployed web applications.
 
Registered jar files (application name, identifier, path):
 
    console  console_jars  /opt/sun/webconsole/lib/*.jar
    console  jato_jar      /opt/sun/share/lib/jato.jar
    console  javahelp_jar  
/usr/java/packages/javax.help-2.0/javahelp/lib/*.jar
    console  shared_jars   
/opt/sun/webconsole/private/container/shared/lib/*.jar
 
Registered login modules (application name, service name, identifier):
 
    console  ConsoleLogin  userlogin
 
Shared service properties (name, value):
 
    ENABLE            yes
"

Miguel

>
> Regards,
>
> Jana Olivova
>
> On 10/09/08 16:13, Miguel Dias Costa wrote:
>> Hello all.
>>
>> I have a working installation of gridengine 6.2 on rhel 4 (x86_64) 
>> and I'm trying to install arco.
>>
>> I've installed all dependencies (java 1.5, mysql 5 and sun web 
>> console 3.0.2) and the installation scripts run fine until it tries 
>> to register the reporting apps on the web console, which fails with 
>> "Must have administration privileges to execute this command."
>>
>> I tracked this to the wcadmin command, which gives the same output 
>> event when I run, as root, "wcadmin list" (it shows everything except 
>> the registered apps, for which it says that it doesn't have permission).
>>
>> Can anyone help me?
>>
>> Kind regards,
>> Miguel
>>
>> P.S. searching the web I noticed that roleLogin is missing from my 
>> "wcadmin list" output. Could this be the problem and, if so, how can 
>> I enable it?
>>
>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
>> For additional commands, e-mail: users-help at gridengine.sunsource.net
>>
>
>
> ------------------------------------------------------------------------
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
> For additional commands, e-mail: users-help at gridengine.sunsource.net


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net




More information about the gridengine-users mailing list