[GE users] Default master's domain name during installation

Michael Green mishagreen at gmail.com
Mon Sep 1 21:01:23 BST 2008


    [ The following text is in the "ISO-8859-1" character set. ]
    [ Your display is set for the "ISO-8859-10" character set.  ]
    [ Some special characters may be displayed incorrectly. ]

Fresh install of 6.1 U5 here.

My master (mcluster05 - shiny new X2200) has two legs:
1. Organization network
132.77.XXX.XXX/23 - wisdom.someorg.com

2. Cluster network
192.168.1.XXX/24 - mcl.someorg.com

in resolv.conf:
search mcl.someorg.com wisdom.someorg.com

During the installation of qmaster I choose to vote yes for "all hosts
of your cluster in a single DNS domain" because all computers of the
grid are on 192.168.1.X network, in mcl.someorg.com domain.

However for a reason that is beyond my understanding the installer
decides to tie shadow master to the wisdom.someorg.com domain instead
of mcl.someorg.com.
[root at mcluster05 common]# qconf -sh
mcluster05.mcl.weizmann.ac.il  <-- master
mcluster05b.wisdom.weizmann.ac.il <-- shadow master (wrong domain)
n21.mcl.weizmann.ac.il <-- exec
n22.mcl.weizmann.ac.il <-- exec
n23.mcl.weizmann.ac.il <-- exec
n24.mcl.weizmann.ac.il <-- exec

(During the addition of  the execution nodes they are all identified
correctly as belonging to mcl.someorg.com domain).

[root at mcluster05 lx24-amd64]# ./gethostbyname -all mcluster05
Hostname: mcluster05.mcl.someorg.com
SGE name: mcluster05.mcl.someorg.com
Aliases:  mcluster05
Host Address(es): 192.168.1.253

root at mcluster05 lx24-amd64]# ./gethostbyaddr -all 192.168.1.253
Hostname: mcluster05.mcl.someorg.com
SGE name: mcluster05.mcl.someorg.com
Aliases:  mcluster05
Host Address(es): 192.168.1.253

However
root at mcluster05 lx24-amd64]# ./gethostbyname -all mcluster05b
Hostname: mcluster05b.wisdom.someorg.com
SGE name: mcluster05b.wisdom.someorg.com
Aliases:  mcluster05b
Host Address(es): 132.77.XXX.YYY

Why?
Is this because what I have in /etc/hosts:

[root at mcluster05 lx24-amd64]# cat /etc/hosts
127.0.0.1       localhost.localdomain   localhost
192.168.1.253   mcluster05.mcl.someorg.com   mcluster05
# 192.168.1.252   mcluster05b.mcl.someorg.com  mcluster05b

I'm pretty sure that I have properly configured BIND serving the
mcl.someorg.com domain just for the purpose of satisfying Grid
resolving needs:
root at mcluster05 lx24-amd64]# host mcluster05
mcluster05.mcl.weizmann.ac.il has address 192.168.1.253
[root at mcluster05 lx24-amd64]# host mcluster05b
mcluster05b.mcl.weizmann.ac.il has address 192.168.1.252

[root at mcluster05 lx24-amd64]# host 192.168.1.253
253.1.168.192.in-addr.arpa domain name pointer mcluster05.mcl.someorg.com.
253.1.168.192.in-addr.arpa domain name pointer ns.mcl.someorg.com.
[root at mcluster05 lx24-amd64]# host 192.168.1.252
252.1.168.192.in-addr.arpa domain name pointer mcluster05b.mcl.someorg.com.

So, how does the installer decides which of the two (or more) domain
names available on the master system to use?

-- 
Warm regards,
Michael Green

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net




More information about the gridengine-users mailing list