[GE users] job suspend / sim license issue

Sathyamoorthy Gopinathan gsat77 at gmail.com
Wed Sep 3 17:24:53 BST 2008


    [ The following text is in the "ISO-8859-1" character set. ]
    [ Your display is set for the "ISO-8859-10" character set.  ]
    [ Some special characters may be displayed incorrectly. ]

Hi reuti

Thanks for the reply.
Yes we also use a custom perl wrapper script submit the job.
the problem is when we try to suspend the job goes to suspend mode but does
not release licenses.
but from the thread i learned that the proceess group needs to get the TSTP
sig using a custom suspend_methoid script.
If you can send me a sample suspend_method script that would be of great
help.


Thanks
Sathya

On Mon, Sep 1, 2008 at 5:54 AM, Reuti <reuti at staff.uni-marburg.de> wrote:

> Hi,
>
> Am 30.08.2008 um 00:02 schrieb Sathyamoorthy Gopinathan:
>
>
>  we are running SGE 6.0 on RH Linux env.
>> we wanted to suspend a job so that it would check in license back to use.
>> when did suspend the status changes to suspend "s" but the job still
>> checks out the license.
>>
>> so tried changing the execd_params with NOTIFY_SUSP=SIGTSTP still we have
>> the same problem.
>> Any help is appriciated.
>>
>
> is this issue similar to this thread:
>
> http://gridengine.sunsource.net/servlets/BrowseList
> ?list=users&by=thread&from=47818
>
> -- Reuti
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
> For additional commands, e-mail: users-help at gridengine.sunsource.net
>
>



More information about the gridengine-users mailing list