[GE users] Automated Install Hangs

Gary Richardson gary.richardson at gmail.com
Wed Sep 17 23:59:59 BST 2008


    [ The following text is in the "ISO-8859-1" character set. ]
    [ Your display is set for the "ISO-8859-10" character set.  ]
    [ Some special characters may be displayed incorrectly. ]

Hey,

I'm trying to get automated execution client installs working. When I run
the install, the execd installs and starts up, but the install process
hangs. If I run top or ps aux | grep inst_sge, it looks like it's
continually forking processes that are exiting:

[root@<removed>] ps auxww | grep inst_
root      9855 10.0  1.5  27456 26240 ttyp0    S    15:47   0:56 /bin/sh
./inst_sge -x -auto /tmp/local.conf -noremote
root      9653  9.7  1.4  27020 25836 ttyp0    R    15:47   0:55 /bin/sh
./inst_sge -x -auto /tmp/local.conf
root     17032  0.0  1.4  27456 25620 ttyp0    R    15:57   0:00 /bin/sh
./inst_sge -x -auto /tmp/local.conf -noremote

In my cluster, I have a master server that exports it's SGE_ROOT directory
as read only through NFS. Execution daemons mount this in the same place on
their system. I'm creating an local execution spool dir.

If I do an interactive install, everything happens properly.

Any advice?

Thanks!



More information about the gridengine-users mailing list