[GE users] Automated Install Hangs

Marco Donauer Marco.Donauer at Sun.COM
Thu Sep 18 16:00:50 BST 2008


    [ The following text is in the "ISO-8859-1" character set. ]
    [ Your display is set for the "ISO-8859-10" character set.  ]
    [ Some special characters may be displayed incorrectly. ]

Gary,

nice to hear that it's working for you, now.
Thanks fo rcreating an issue, we will care about.
I think it would be a good option to make the logfile configurable.

Marco

On 09/18/08 16:55, Gary Richardson wrote:
> that output was from /tmp/install.30775 :)
>
> Changing the variable solved the problem. My installs work perfectly now.
>
> I've created a ticket as well: 
> http://gridengine.sunsource.net/issues/show_bug.cgi?id=2733
>
> Thanks for the help!
>
> On Wed, Sep 17, 2008 at 11:30 PM, Marco Donauer <Marco.Donauer at sun.com 
> <mailto:Marco.Donauer at sun.com>> wrote:
>
>     Gary,
>
>     the installation creates the install log file in /tmp, after a
>     successful installation this file would be moved to
>     mnt/grid/l268/sgeadmin/default/common/install_logs/
>     Your output shows that the log file copy does not work. You're
>     writing that SGE_ROOT is read only, this could be the problem why
>     the log file can't be copied.
>     This could be a bug. If you want to see the debug output, you
>     could have a look into this /tmp/install.30775 file.
>
>     There is currently no way to change the logging directory, but
>     looking into SGE_ROOT/util/install_modules/inst_common.sh, you
>     will find a function called MoveLog().
>     In this function you will find a line:
>     install_log_dir="$SGE_ROOT/$SGE_CELL/common/install_logs"
>     Change this to your own need, please. If you could send me your
>     log file, I will have a look on it
>
>     Regards,
>     Marco
>
>
>     On 09/18/08 01:32, Gary Richardson wrote:
>>     good call. It looks like it's trying to copy the log file to the
>>     install log dir:
>>
>>     + /bin/echo -e
>>
>>     + ./utilbin/lx24-x86/infotext -log 'Command failed: %s' cp -f
>>     /tmp/install.30775
>>     /mnt/grid/l268/sgeadmin/default/common/install_logs/execd_install_ip-10-251-126-21_2008-09-17_16:26:33.log
>>     Command failed:
>>     /mnt/grid/l268/sgeadmin/default/common/install_logs/execd_install_ip-10-251-126-21_2008-09-17_16:26:33.logcp-f/tmp/install.30775
>>     + ./utilbin/lx24-x86/infotext -log 'Probably a permission
>>     problem. Please check file access permissions.'
>>     Probably a permission problem. Please check file access permissions.
>>     + ./utilbin/lx24-x86/infotext -log 'Check read/write permission.
>>     Check if SGE daemons are running.'
>>     Check read/write permission. Check if SGE daemons are running.
>>
>>     I don't see anywhere in the config template to specify a
>>     different logging directory. Is there a way?
>>
>>     Thanks!
>>
>>     On Wed, Sep 17, 2008 at 4:18 PM, Chris Dagdigian
>>     <dag at sonsorol.org <mailto:dag at sonsorol.org>> wrote:
>>
>>         Hi Gary,
>>
>>         This is what I do when debugging auto install failures:
>>
>>         Edit the inst_sge script and change the first line to
>>         "/bin/sh -x" to enable debug output. You'll get a massive
>>         flood of output but in my experience it usually shows exactly
>>         where and why the error is happening.
>>
>>         -Chirs
>>
>>
>>
>>
>>         On Sep 17, 2008, at 6:59 PM, Gary Richardson wrote:
>>
>>             Hey,
>>
>>             I'm trying to get automated execution client installs
>>             working. When I run the install, the execd installs and
>>             starts up, but the install process hangs. If I run top or
>>             ps aux | grep inst_sge, it looks like it's continually
>>             forking processes that are exiting:
>>
>>             [root@<removed>] ps auxww | grep inst_
>>             root      9855 10.0  1.5  27456 26240 ttyp0    S    15:47
>>               0:56 /bin/sh ./inst_sge -x -auto /tmp/local.conf -noremote
>>             root      9653  9.7  1.4  27020 25836 ttyp0    R    15:47
>>               0:55 /bin/sh ./inst_sge -x -auto /tmp/local.conf
>>             root     17032  0.0  1.4  27456 25620 ttyp0    R    15:57
>>               0:00 /bin/sh ./inst_sge -x -auto /tmp/local.conf -noremote
>>
>>             In my cluster, I have a master server that exports it's
>>             SGE_ROOT directory as read only through NFS. Execution
>>             daemons mount this in the same place on their system. I'm
>>             creating an local execution spool dir.
>>
>>             If I do an interactive install, everything happens properly.
>>
>>             Any advice?
>>
>>             Thanks!
>>
>>
>>
>>         ---------------------------------------------------------------------
>>         To unsubscribe, e-mail:
>>         users-unsubscribe at gridengine.sunsource.net
>>         <mailto:users-unsubscribe at gridengine.sunsource.net>
>>         For additional commands, e-mail:
>>         users-help at gridengine.sunsource.net
>>         <mailto:users-help at gridengine.sunsource.net>
>>
>>
>
>     -- 
>
>     Sun Microsystems GmbH         Marco Donauer
>     Dr.-Leo-Ritter-Str. 7         SUN Grid Engine Engineering
>     D-93049 Regensburg            Phone: +49 (0)941 3075-211  (x60211)
>     Germany                       Fax: +49 (0)941 3075-222  (x60222)
>     http://www.sun.com/gridware
>     mailto:marco.donauer at sun.com
>     Sitz der Gesellschaft: Sun Microsystems GmbH, Sonnenallee 1, 
>     D-85551 Kirchheim-Heimstetten
>     Amtsgericht Muenchen: HRB 161028
>     Geschaeftsfuehrer: Thomas Schroeder, Wolfgang Engels, Dr. Roland Boemer
>     Vorsitzender des Aufsichtsrates: Martin Haering 
>         
>
>

-- 

Sun Microsystems GmbH         Marco Donauer
Dr.-Leo-Ritter-Str. 7         SUN Grid Engine Engineering
D-93049 Regensburg            Phone: +49 (0)941 3075-211  (x60211)
Germany                       Fax: +49 (0)941 3075-222  (x60222)
http://www.sun.com/gridware
mailto:marco.donauer at sun.com
Sitz der Gesellschaft: Sun Microsystems GmbH, Sonnenallee 1, 
D-85551 Kirchheim-Heimstetten
Amtsgericht Muenchen: HRB 161028
Geschaeftsfuehrer: Thomas Schroeder, Wolfgang Engels, Dr. Roland Boemer
Vorsitzender des Aufsichtsrates: Martin Haering 




More information about the gridengine-users mailing list