[GE users] UNSUPPORTED-lx26-GLIBC-2.8-amd64

Sean Davis sdavis2 at mail.nih.gov
Mon Sep 22 18:33:22 BST 2008


    [ The following text is in the "UTF-8" character set. ]
    [ Your display is set for the "ISO-8859-10" character set.  ]
    [ Some characters may be displayed incorrectly. ]

On Mon, Sep 22, 2008 at 1:16 PM, Sean Davis <sdavis2 at mail.nih.gov> wrote:
> On Mon, Sep 22, 2008 at 1:06 PM, Sean Davis <sdavis2 at mail.nih.gov> wrote:
>> On Mon, Sep 22, 2008 at 12:49 PM, Reuti <reuti at staff.uni-marburg.de> wrote:
>>> Am 22.09.2008 um 18:27 schrieb Rayson Ho:
>>>
>>>> I believe the "arch" script has problems with parsing the kernel
>>>> and/or glibc version on your system. You can execute util/arch
>>>> directly from the shell prompt, and see if it is returning
>>>> "UNSUPPORTED". Then you can run the script with debug on:
>>>>
>>>> % sh -xv util/arch
>>>>
>>>> Also, let the list know what is causing the failure...
>>>
>>> Also: what is
>>>
>>> uname -m
>>>
>>> saying? - Reuti
>>
>> Thanks, Reuti and Rayson.
>>
>> Grass:~ # /import/cluster/sge/util/arch
>> UNSUPPORTED-lx26-GLIBC-2.8-amd64
>> Grass:~ # uname -m
>> x86_64
>>
>> I've not used debug output before, and there is a TON of it with arch,
>> so I'll try to sort out what is going on directly.
>
> So, it appears that the arch script does not believe that glibc-2.8 is
> supported.  There is support for 2.[3-6]*.  Any reason not to edit the
> arch script to include through 2.8?

I got impatient and changed 2.[3-6]* to 2.[3-8]* which will end up
running the 2.4 binaries (I think) and things work just fine, it
seems.

Sean

> Here is the relevant section from arch script, it seems:
>
> ------------------------------------
>      # verify the GNU C lib version
>      # For an alternative means to determine GNU C lib version see
>      # http://www.gnu.org/software/libc/FAQ.html#s-4.9
>      case $lxmachine in
>      amd64)
>         libc=`/lib64/libc.so.6 2>/dev/null | head -1`
>         ;;
>      ia64)
>         libc=`/lib/libc.so.6.1 2>/dev/null | head -1`
>         ;;
>      *)
>         libc=`/lib/libc.so.6 2>/dev/null | head -1`
>         ;;
>      esac
>      libc=`echo $libc | sed -e 's/^.*version//'`
>      libc=`echo $libc | cut -d ' ' -f1`
>
>      case $libc in
>      2.2*)
>         unsupported="u"
>         ;;
>      2.[3-6]*)
>         ;;
>      *)
>         unsupported="UNSUPPORTED-"
>         lxrelease=${lxrelease}-GLIBC-${libc}
>      esac
> -------------------------------
>
> Thanks,
> Sean
>
>
>>>> On 9/22/08, Sean Davis <sdavis2 at mail.nih.gov> wrote:
>>>>>
>>>>> I am trying to install execd (6.2b1) services on a new machine.  The
>>>>> install_execd script complains:
>>>>>
>>>>> # ./install_execd
>>>>> Architecture UNSUPPORTED-lx26-GLIBC-2.8-amd64 not supported by this
>>>>> procedure!
>>>>>
>>>>> # uname -a
>>>>> Linux Grass 2.6.25.16-0.1-default #1 SMP 2008-08-21 00:34:25 +0200
>>>>> x86_64 x86_64 x86_64 GNU/Linux
>>>>>
>>>>> Any suggestions?
>>>>>
>>>>> Thanks,
>>>>> Sean
>>>>>
>>>>> ---------------------------------------------------------------------
>>>>> To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
>>>>> For additional commands, e-mail: users-help at gridengine.sunsource.net
>>>>>
>>>>>
>>>>
>>>> ---------------------------------------------------------------------
>>>> To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
>>>> For additional commands, e-mail: users-help at gridengine.sunsource.net
>>>
>>>
>>> ---------------------------------------------------------------------
>>> To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
>>> For additional commands, e-mail: users-help at gridengine.sunsource.net
>>>
>>>
>>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net




More information about the gridengine-users mailing list