[GE users] SGE-6.0u7: sort by seq_no works only for parallel jobs.

Reuti reuti at staff.uni-marburg.de
Thu Sep 25 13:55:00 BST 2008


Hi,

Am 25.09.2008 um 14:44 schrieb Erik Soyez:

> after hours of debugging I have just discovered a very peculiar
> phenomenon.  Our customer has sorted hosts within one queue by
> sequence numbers in order to get jobs running on fast machines
> first.  This works as expected for jobs requesting a PE.  But it
> does not work for serial jobs.  Strange enough, those are sorted
> neither by seqno nor by load.

a plain:

qstat -f

should also list them in the seq_no order (and alphabetical within  
the same seq_no). You get what output order there?

-- Reuti


> Is it a known bug of 6.0u7?  An unkonwn bug?  No bug but a feature?
>
> It's okay now as they simply request "-pe smp 1".  I hope that it
> will work normally again once they upgrade to some later version
> but maybe one of you knows more about it (Reuti?  Chris?  Mark?).
>
> Thanx!  Erik Soyez.
>
> --
>
> -- 
> Vorstand/Board of Management:
> Dr. Bernd Finkbeiner, Dr. Florian Geyer,
> Dr. Roland Niemeier, Dr. Arno Steitz, Dr. Ingrid Zech
> Vorsitzender des Aufsichtsrats/
> Chairman of the Supervisory Board:
> Prof. Dr. Hanns Ruder
> Sitz/Registered Office: Tuebingen
> Registergericht/Registration Court: Stuttgart
> Registernummer/Commercial Register No.: HRB 382196
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
> For additional commands, e-mail: users-help at gridengine.sunsource.net


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net




More information about the gridengine-users mailing list