[GE users] SGE-6.0u7: sort by seq_no works only for parallel jobs.

Olesen, Mark Mark.Olesen at emcontechnologies.com
Thu Sep 25 14:29:19 BST 2008


> after hours of debugging I have just discovered a very peculiar
> phenomenon.  Our customer has sorted hosts within one queue by
> sequence numbers in order to get jobs running on fast machines
> first.  This works as expected for jobs requesting a PE.  But it
> does not work for serial jobs.  Strange enough, those are sorted
> neither by seqno nor by load.

A few months ago I posted about a similar issue with 6.1u3 where the
seqno is apparently ignored when dispatching parallel jobs. I don't know
if this also applies to serial jobs, since I never have any.

I'm really hoping this strangeness is gone in 6.2 (since dispatch and
scheduling have been re-worked) ... I just need time to
install/test/dispatch.

/mark
This e-mail message and any attachments may contain 
legally privileged, confidential or proprietary Information, 
or information otherwise protected by law of EMCON 
Technologies, its affiliates, or third parties. This notice 
serves as marking of its "Confidential" status as defined 
in any confidentiality agreements concerning the sender 
and recipient. If you are not the intended recipient(s), 
or the employee or agent responsible for delivery of this 
message to the intended recipient(s), you are hereby 
notified that any dissemination, distribution or copying 
of this e-mail message is strictly prohibited. 
If you have received this message in error, please 
immediately notify the sender and delete this e-mail 
message from your computer.


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net




More information about the gridengine-users mailing list