[GE users] howto set qsub -q to a job, and keep it that way?

Matthias Neder matthias.neder at gmail.com
Mon Sep 29 13:49:59 BST 2008


    [ The following text is in the "UTF-8" character set. ]
    [ Your display is set for the "ISO-8859-10" character set.  ]
    [ Some characters may be displayed incorrectly. ]

Dear List,

i am currently trying to set the used queue to a certain one.

The Problem i have is like this:

command used:
bash [root]# qmake -q high-mem.q -l arch=lx24-amd64 -v PATH=`echo $PATH`
-cwd -- -j 40 s_5 ;

the result is this:
###################
8690 0.55500 sh         root         t     09/29/2008 14:43:56
all.q at Node-192-168-60-161.inte MASTER
<---wrong queue, but its a child job ?!
8692 0.55500 sh         root         t     09/29/2008 14:43:56
all.q at Node-192-168-60-162.inte MASTER
8691 0.55500 sh         root         t     09/29/2008 14:43:56
all.q at Node-192-168-60-163.inte MASTER
8693 0.55500 sh         root         t     09/29/2008 14:43:56
all.q at cluster1node10.intern.ga MASTER
8653 0.55500 qmake      root         r     09/29/2008 14:43:41
high-mem.q at Node-192-168-60-161 MASTER                        <---- the
correct queue
8669 0.55500 sh         root         t     09/29/2008 14:43:56
high-mem.q at Node-192-168-60-161 MASTER
8680 0.55500 sh         root         t     09/29/2008 14:43:56
high-mem.q at Node-192-168-60-161 MASTER

The make is spawning some new processes which are queued as well, but in the
wrong queues, so how do i prevent this?
I only want to use the high-mem.q.

Someone got an idea how i can do that? I tried it with accounts, but if i
submit the jobs under the root account and set -A john the jobs are still
send to the other queues.

Any help is appreciated.

Thx Matthias



More information about the gridengine-users mailing list