[GE users] sge on Mac 10.5 non-server OS

Brett W Grant Brett_W_Grant at raytheon.com
Mon Sep 29 19:45:58 BST 2008


In looking this over this weekend, I realized that I made an error.  The 
clients are working just fine, it is the Server that is not.  I thought 
that I had it all figured out.  It was working on Friday, Saturday, 
Sunday, but when I came in today, the entire grid was not working.  The 
act_master file had changed.  I am not really sure of what has happened. I 
need to look at it some more.

So far, I can not find any error messages in any logs.  Do you have a 
suggestion on where to look?

Thanks,
Brett Grant




"Jonathan Hunt" <jjh at 42quarks.com> 
09/26/2008 05:53 PM
Please respond to
users at gridengine.sunsource.net


To
users at gridengine.sunsource.net
cc

Subject
Re: [GE users] sge on Mac 10.5 non-server OS






Hi Brett,

Launchd should work on non-server OSes (I haven't tried SGE
specifically, but I use launchd to run Ganglia).

What is the error message you are getting when using launchd? In
/var/log/system.log or elsewhere?

Jonny

On Sat, Sep 27, 2008 at 4:19 AM, Brett W Grant
<Brett_W_Grant at raytheon.com> wrote:
>
> I have a cluster of servers running Mac 10.4.9 using sge 6.1.  These 
work
> great.  I am trying to add a couple of desktop machines to this cluster.
>  One of them has 10.5.4 Server, the other just 10.5.4.  I am having 
other
> issues with the tiger desktops, but I will deal with those in another 
post
> if I can't figure them out.  The hints on using the launchd from the 
bioteam
> worked great for the server o.s. but they don't on the non-server o.s. 
When
> I tried to use the lauchd scripts, I simply got a message that the 
service
> could not start.  When I use the old SGE_ROOT/default/common/sgeexecd
> command, it starts up and runs a variable amount of time before I start
> getting the password errors.
>
> I was wondering if one of the reasons that it may not be working is that 
I
> am running 6.1?  Most of the comments seem to indicate people were using 
at
> least 6.1u3.
>
> I'll be honest in saying that I have no clue about launchd/launchctl and 
am
> unsure of how to even debug it.  This is a G5 powerpc processor.
>
> Thanks for any insight,
> Brett Grant
>



-- 
Jonathan J Hunt <jjh at 42quarks.com>
Homepage: http://www.42quarks.net.nz/wiki/JJH
(Further contact details there)
"Physics isn't the most important thing. Love is." Richard Feynman

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net







More information about the gridengine-users mailing list