[GE users] DRMAA submit with resource request, complex (loadsensor)

jerry37 jerry37 at seznam.cz
Fri Aug 28 19:15:42 BST 2009


Hello,

I'm having some problems submitting job with DRMAA while successfully submitting the very same job with qsub command. The problem which I encounter is caused by resource request on complex which is being filled with load sensor. In that case, when I specify "drmaa_native_specification" (in my case "-l scratch_size=10M"), it gives me message "error: no suitable queues" when calling drmaa_run_job.

Log of the shell session:
testuser at laptop:~$ . /opt/sge/default/common/settings.sh
testuser at laptop:~$ export LD_LIBRARY_PATH=/opt/sge/lib/lx24-amd64
testuser at laptop:~$ gcc -I/opt/sge/include -L/opt/sge/lib/lx24-amd64 subdrmaa.c -ldrmaa -o subdrmaa
testuser at laptop:~$ ./subdrmaa
drmaa: error: no suitable queues
testuser at laptop:~$ qsub -b no -N test -h -o test.out -j y -l scratch_size=10M test.sh
Your job 82752 ("test") has been submitted
testuser at laptop:~$ qstat | grep test
  82752 0.00000 test       testuser     hqw   08/28/2009 19:47:45                                    1        
testuser at laptop:~$ qstat -F scratch_size | grep -c "hl:scratch_size=[0-9]\{3,5\}\.[0-9]\+G"
172
testuser at laptop:~$ 

subdrmaa.c is attached, it was written on-purpose of isolating this error and contains just the necessary code to submit the same job with the same requests/arguments.

SGE version used is 6.1u6.

Is there version/update/patch that fixes this?

Thanks!
   Jerry

------------------------------------------------------
http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=38&dsMessageId=214773

To unsubscribe from this discussion, e-mail: [users-unsubscribe at gridengine.sunsource.net].

    [ Part 2, "subdrmaa.c"  Text/X-CSRC (Name: "subdrmaa.c") ~1.2 KB. ]
    [ Unable to print this part. ]



More information about the gridengine-users mailing list