[GE users] DRMAA submit with resource request, complex (loadsensor)

jerry37 jerry37 at seznam.cz
Sat Aug 29 07:45:38 BST 2009


Thanks Daniel,

that was  the cause. I missed this info - drmaa_attributes(3):
"By default DRMAA sets four options for all jobs.  These are "-p 0", "-b yes", "-shell no", and "-w e".  This means that by  default,  all  jobs will  have  priority  0,  all  jobs  will be treated as binary, i.e. no scripts args will be parsed, all jobs will be executed without a  wrapper  shell, and jobs which are unschedulable will cause a submit error."

Regards,
  Jerry

> ------------ Original message ------------
> From: templedf <dan.templeton at sun.com>
> Subject: Re: [GE users] DRMAA submit with resource request, complex (loadsensor)
> Date: 28.8.2009 23:30:46
> ----------------------------------------
> That's because DRMAA rejects jobs that cannot be scheduled as the 
> default behavior.  To turn off that behavior, add "-w n" to your native 
> specification.
> 
> Daniel
> 
> jerry37 wrote:
> > Hello,
> >
> > I'm having some problems submitting job with DRMAA while successfully
> submitting the very same job with qsub command. The problem which I encounter is
> caused by resource request on complex which is being filled with load sensor. In
> that case, when I specify "drmaa_native_specification" (in my case "-l
> scratch_size=10M"), it gives me message "error: no suitable queues" when calling
> drmaa_run_job.
> >
> > Log of the shell session:
> > testuser at laptop:~$ . /opt/sge/default/common/settings.sh
> > testuser at laptop:~$ export LD_LIBRARY_PATH=/opt/sge/lib/lx24-amd64
> > testuser at laptop:~$ gcc -I/opt/sge/include -L/opt/sge/lib/lx24-amd64 subdrmaa.c
> -ldrmaa -o subdrmaa
> > testuser at laptop:~$ ./subdrmaa
> > drmaa: error: no suitable queues
> > testuser at laptop:~$ qsub -b no -N test -h -o test.out -j y -l scratch_size=10M
> test.sh
> > Your job 82752 ("test") has been submitted
> > testuser at laptop:~$ qstat | grep test
> >   82752 0.00000 test       testuser     hqw   08/28/2009 19:47:45             
>                       1        
> > testuser at laptop:~$ qstat -F scratch_size | grep -c
> "hl:scratch_size=[0-9]\{3,5\}\.[0-9]\+G"
> > 172
> > testuser at laptop:~$ 
> >
> > subdrmaa.c is attached, it was written on-purpose of isolating this error and
> contains just the necessary code to submit the same job with the same
> requests/arguments.
> >
> > SGE version used is 6.1u6.
> >
> > Is there version/update/patch that fixes this?
> >
> > Thanks!
> >    Jerry
> > ------------------------------------------------------
> >
> http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=38&dsMessageId=214773
> >
> > To unsubscribe from this discussion, e-mail:
> [users-unsubscribe at gridengine.sunsource.net].
> ------------------------------------------------------
> http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=38&dsMessageId=214787
> 
> To unsubscribe from this discussion, e-mail:
> [users-unsubscribe at gridengine.sunsource.net].

------------------------------------------------------
http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=38&dsMessageId=214847

To unsubscribe from this discussion, e-mail: [users-unsubscribe at gridengine.sunsource.net].



More information about the gridengine-users mailing list