[GE users] debugging tight integration

aja alena.plestilova at sun.com
Tue Dec 1 17:23:19 GMT 2009


Hi,

I don't know what reuti suggested so I might be repeating...
How I debug the tight integration tasks: submit a job, set the 
environment variable JOB_ID to the job's number, SGE_TASK_ID to 
undefined, or to the required task nubmer ..
You can also try to debug with "dl 1" (source $SGE_ROOT/util/dl.sh or 
dl.csh depending on your shell) and start qrsh in this mode.

hope this helps,
aja


fx wrote:
> Are there any general suggestions for debugging tight integration?  (I
> guess the answer is yes, but they're not easy to find in the archives.)
>
> I have a situation where the processes appear to be started OK by qrsh
> -inherit according to what the wrapper echoes, but aren't children of
> the shepherd when they're running.  (It's actually gamess-us, using just
> what reuti provided, or an alternative, explicitly specifying the rsh
> command for gamess to use.)  I wonder why it works in Marburg and not
> Liverpool, and reuti ran out of suggestions.  Initially I thought it
> might be due to the ancient SGE currently in use although tight
> integration of openmpi, for instance, works fine; however, it's the same
> under a 6.2u2 that I tried.
>
> Any debugging ideas or pointers to write-ups gratefully received!
>
> ------------------------------------------------------
> http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=38&dsMessageId=227992
>
> To unsubscribe from this discussion, e-mail: [users-unsubscribe at gridengine.sunsource.net].
>   


-- 
aja && sun
e-mail: aja at sun.com

------------------------------------------------------
http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=38&dsMessageId=230752

To unsubscribe from this discussion, e-mail: [users-unsubscribe at gridengine.sunsource.net].



More information about the gridengine-users mailing list