[GE users] mpich2 smpd

reuti reuti at staff.uni-marburg.de
Fri Dec 11 12:20:12 GMT 2009


Hi,

Am 11.12.2009 um 07:06 schrieb udo:

> A short question.
> There is a problem with tight MPICH2 Integration in Grid Engine (smpd
> implementation). Namely when two or more jobs start they all  
> rewrite .smpd
> file and sometimes phrase=secret_word disappears and jobs die.
> Browsing inet I found this  option

setting:

> export SMPD_OPTION_NO_DYNAMIC_HOSTS=1

is essential and it's also mentioned my Howto: http:// 
gridengine.sunsource.net/howto/mpich2-integration/mpich2- 
integration.html

> which doesn't work as it doesn't exists neither in mpich2 nor in SGE
> installation directories.

What do you mean by: it doesnt exist?

I just checked with mpich2-1.2.1 and to me it appears still working  
fine with this setting.

-- Reuti


> Any suggestions, advices etc. how to avoid this problem?
> Thank you very much in advance.
> Best,
> Victor
> p.s. i found one more solution which I need to try but I do not  
> know how
> good or bad  it is i.e. to change starting mpich2 script in
> <SGE_ROOT>/mpich_smpd directory and along with -port add one more smpd
> option -phrase <passphrase> .
>
> ------------------------------------------------------
> http://gridengine.sunsource.net/ds/viewMessage.do? 
> dsForumId=38&dsMessageId=232723
>
> To unsubscribe from this discussion, e-mail: [users- 
> unsubscribe at gridengine.sunsource.net].

------------------------------------------------------
http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=38&dsMessageId=232775

To unsubscribe from this discussion, e-mail: [users-unsubscribe at gridengine.sunsource.net].



More information about the gridengine-users mailing list