[GE users] Windows load sensor issue

pollinger harald.pollinger at sun.com
Wed Dec 16 12:58:01 GMT 2009


Is this perhaps some shell issue?

What happens if you configure a load sensor script that just forwards to 
a file what it receives from stdin?


Regards,
Harald


On 12/15/09 00:17, opoplawski wrote:
> On 12/14/2009 02:17 PM, opoplawski wrote:
>> On 12/08/2009 05:15 PM, opoplawski wrote:
>>> Trying to install 6.2u4 on a Windows Server 2008 r2 machine.  Getting
>>> the following in the logs:
>>>
>>> 12/08/2009 17:07:01|  main|FONTDB|W|[load_sensor 1337] fflush failed
>>> [Broken pipe]
>>> 12/08/2009 17:07:01|  main|FONTDB|W|load sensor exited with exit status
>>> = 126
> 
> 
> I put:
> 
> exec 2>/tmp/load.log
> set -x
> 
> at the top of interix-loadsensor.sh but /tmp/load.log is not created 
> unless I run it by hand.
> 
> Running under debug mode I see:
> 
>     320   1587         main --> sge_ls_get() {
>     321   1587         main --> sge_ls_start() {
>     322   1587         main --> sge_ls_create_ls() {
>     323   1587         main <-- sge_ls_create_ls() 
> ../daemons/execd/sge_load_sensor.c 316 }
>     324   1587         main <-- sge_ls_start() 
> ../daemons/execd/sge_load_sensor.c 761 }
>     325   1587         main --> sge_ls_stop_ls() {
>     326   1587         main --> ls_send_command() {
>     327   1587         main <-- ls_send_command() 
> ../daemons/execd/sge_load_sensor.c 580 }
>     328   1587         main --> sge_ls_status() {
>     329   1587         main <-- sge_ls_status() 
> ../daemons/execd/sge_load_sensor.c 191 }
>     330   1587         main --> sge_peclose() {
>     331   1587         main <-- sge_peclose() ../libs/uti/sge_stdio.c 641 }
>     332   1587         main     sge_ls_stop_ls: load sensor 
> `/usr/share/gridengine/util/resources/loadsensors/interix-loadsensor.sh` 
> stopped, exit status from sge_peclose= -1
>     333   1587         main <-- sge_ls_stop_ls() 
> ../daemons/execd/sge_load_sensor.c 402 }
>     334   1587         main --> sge_ls_start_ls() {
>     335   1587         main --> sge_peopen() {
>     336   1587         main <-- sge_peopen() ../libs/uti/sge_stdio.c 287 }
>     337   1587         main     sge_ls_start_ls: successfully started 
> load sensor 
> "/usr/share/gridengine/util/resources/loadsensors/interix-loadsensor.sh"
>     338   1587         main --> ls_send_command() {
>     339   1587         main <-- ls_send_command() 
> ../daemons/execd/sge_load_sensor.c 583 }
>     340   1587         main --> read_ls() {
>     341   1587         main     receiving from 
> /usr/share/gridengine/util/resources/loadsensors/interix-loadsensor.sh
>     342   1587         main <-- read_ls() 
> ../daemons/execd/sge_load_sensor.c 504 }
>     343   1587         main <-- sge_ls_get() 
> ../daemons/execd/sge_load_sensor.c 916 }
> 
> So it thinks it started it fine, but never receives input.
> 


-- 
Sun Microsystems GmbH         Harald Pollinger
Dr.-Leo-Ritter-Str. 7         Sun Grid Engine Engineering
D-93049 Regensburg            Phone: +49 (0)941 3075-209  (x60209)
Germany                       Fax: +49 (0)941 3075-222  (x60222)
http://www.sun.com/gridware
mailto:harald.pollinger at sun.com
Sitz der Gesellschaft:
Sun Microsystems GmbH, Sonnenallee 1, D-85551 Kirchheim-Heimstetten
Amtsgericht Muenchen: HRB 161028
Geschaeftsfuehrer: Thomas Schroeder, Wolfgang Engels, Wolf Frenkel
Vorsitzender des Aufsichtsrates: Martin Haering

------------------------------------------------------
http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=38&dsMessageId=233705

To unsubscribe from this discussion, e-mail: [users-unsubscribe at gridengine.sunsource.net].



More information about the gridengine-users mailing list