[GE users] GE6.2 num_proc consumable strange behavior for mpi $fillup jobs

jlopez jlopez at cesga.es
Tue Feb 3 16:27:30 GMT 2009


> Yeah, if you define a completely new complex it should work. It's  
> something like a license or so. I never dared to touch num_proc,  
> therefore I suggested to stay with slots and it will work, but I also  
> see a strange behavior, giving negative values for a consumable.
>
> $ qhost -F num_proc2
> HOSTNAME                ARCH         NCPU  LOAD  MEMTOT  MEMUSE   
> SWAPTO  SWAPUS
> ------------------------------------------------------------------------ 
> -------
> global                  -               -     -       -       -        
> -       -
> pc15370                 lx24-x86        1  0.03  979.9M   42.2M   
> 517.7M     0.0
>     hc:num_proc2=-4.000000
>
> Okay, it's an issue - can you please file one (note: it's still in  
> 6.2u1 on my cluster). Thx for getting to the root of it.
>
> This might also explains the negative slot count some observed, and  
> it seems only by coincidence that it never happend on my cluster as  
> have no $fill_up. Maybe resources are subtracted after the slot  
> allocation is done without checking their availability.
>
> -- Reuti
>
>
>   
Issue 2901 posted.

Thanks for all your help,
Javier

------------------------------------------------------
http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=38&dsMessageId=101715

To unsubscribe from this discussion, e-mail: [users-unsubscribe at gridengine.sunsource.net].

    [ Part 2, Text/X-VCARD (charset: UTF-8 "Internet-standard Unicode") ]
    [ (Name: "jlopez.vcf") 14 lines. ]
    [ Unable to print this part. ]



More information about the gridengine-users mailing list