[GE users] Error: Job rejected: no project assigned to job, Possible bug in qmake

reuti reuti at staff.uni-marburg.de
Tue Feb 10 22:29:09 GMT 2009


Hi,

Am 10.02.2009 um 23:15 schrieb abhishekpratap:

> Hi  All
>
>
> Diving into some more details, this is what I find out. I believe  
> it to be a possible bug or some silly thing that I am not aware of.
>
> The problem lies with the script I am submitting via qsub as  
> described below. I think qmake is not able to pass the parameter -P  
> general to its implicit qrsh call. I have tried to explain it below.
> ================
>
> > Submitting a job here:
> >
> > qsub -P general -S /bin/sh -q sequencing.q -cwd -v PATH -pe make  
> 1-10
> > /home/apratap/dev/GRID/qsubmake
>
> > where qsubmake is a simple script like this:
> >
> >
> > #!/bin/sh
> >
> > qmake -P general -cwd -v PATH -inherit --recursive

the --recursive should go to the make - or to what command? Can you try:

qmake -P general -cwd -v PATH -inherit -- --recursive

The -- will end the options to qmake.

-- Reuti


> >
>
> >
>
> >
>
> > ===============
>
>  I just tried fiddling with qmake running it directly on shell with/ 
> without -P option. Here is -P is the project tag which is required  
> as per the policy set up by SGE admins here.
>
>  ____________________________________________________________
>
> 1. qmake -cwd -v PATH -pe make 1-10 --
>
>
>
> qmake: *** cannot determine architecture from environment variable  
> SGE_ARCH
>
>            no default architecture set
>
> job rejected: no project assigned to job
>
>
>
> NOW I tried with -P option .
>
> _________________________________________________________
>
> 2. qmake -P general -cwd -V -v PATH -pe make 1-10 --
>
>
>
> qmake: *** cannot determine architecture from environment variable  
> SGE_ARCH
>
>            no default architecture set
>
> Your "qrsh" request could not be scheduled, try again later.
>
> ______________________________________________________________
>
>
>
> I also tried qrsh with/without -P general
>
>
>
> qrsh
>
> job rejected: no project assigned to job
>
> qrsh -P general
>
> It works this time without any error.
>
>  Thanks,
>
> -Abhi
>
>
>
> -----Original Message-----
>
> From: Pratap, Abhishek
> Sent: Tuesday, February 10, 2009 3:24 PM
> To: 'users'
> Subject: RE: job rejected: no project assigned to job (was Re: [GE  
> users] Parallelizing the GA pipeline at tile level)
>
>  Hi Chris
>
>  Thanks for your suggestion. I agree it sounds more generic now.
> I am not the one who created this project. IT has done it here.
>
> Output of qconf -sprjl
>
>
> qconf -sprjl
> dacc
> general
> global
> testing
>
>
> Also I would like to know does qmake has a similar behavior as  
> qsub. I am not able to find much documentation on qmake and how it  
> can be used.
>
>
> Thanks,
> -Abhi
>
>
>
> -----Original Message-----
>
> From: craffi [mailto:dag at sonsorol.org]
>
> Sent: Tuesday, February 10, 2009 3:15 PM
>
> To: users at gridengine.sunsource.net
>
> Subject: job rejected: no project assigned to job (was Re: [GE  
> users] Parallelizing the GA pipeline at tile level)
>
>
>
> Abhi,
>
>
>
> This is a general mailing list for Grid Engine users, 99% of the  
> people here will have no idea what you are talking about when you  
> say "GA pipeline" (although there are a few Solexa/Illumina Genome  
> Analyzer pipeline users here), I'm replying mostly to change the  
> subject line of the thread to actually match the problem you are  
> having -- namely getting SGE to accept the fact that you have named  
> a project via "-P" ...
>
>
>
> It is clear that you are assigning a project, have you actually  
> created this project?
>
>
>
> What is the output of the command:
>
>
>
> $ qconf -sprjl
>
>
>
>
>
> -Chris
>
>
>
>
>
>
>
>
>
>
>
>
>
> On Feb 10, 2009, at 3:04 PM, abhishekpratap wrote:
>
>
>
> > Hi All
>
> >
>
> > I am trying to work on parallelizing the GA pipeline to the tile
>
> > level. Just wondering if any one has already worked or working on  
> the
>
> > same.
>
> >
>
> > Let me know if you have some notes to do the same. I am not getting
>
> > much doc on how to use qmake for this.
>
> >
>
> > This is what I have done so far with some pointers from people  
> but not
>
> > with much success
>
> >
>
> > ================
>
> > Running this from the Bustard folder:
>
> >
>
> >
>
> > qsub -P general -S /bin/sh -q sequencing.q -cwd -v PATH -pe make  
> 1-10
>
> > /home/apratap/dev/GRID/qsubmake
>
> >
>
> >
>
> > where qsubmake is a simple script like this:
>
> >
>
> >
>
> > #!/bin/sh
>
> >
>
> > qmake -P general -cwd -v PATH -inherit --recursive
>
> >
>
> >
>
> >
>
> >
>
> > ===============
>
> >
>
> >
>
> > Executing this gives me this error  "job rejected: no project  
> assigned
>
> > to job"
>
> >
>
> > I have already associated a Project (-P general), not sure why I am
>
> > getting this error.
>
> >
>
> >
>
> >
>
> >
>
> >
>
> >
>
> > Thanks,
>
> > -Abhi
>
>
>
> ------------------------------------------------------
>
> http://gridengine.sunsource.net/ds/viewMessage.do? 
> dsForumId=38&dsMessageId=103266
>
>
>
> To unsubscribe from this discussion, e-mail: [users- 
> unsubscribe at gridengine.sunsource.net].
>

------------------------------------------------------
http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=38&dsMessageId=103277

To unsubscribe from this discussion, e-mail: [users-unsubscribe at gridengine.sunsource.net].



More information about the gridengine-users mailing list